Problem changing window manager  Topic is solved

The standard session manager used by LXDE - http://wiki.lxde.org/en/LXSession

Problem changing window manager

Postby Fejodor » Sat Oct 15, 2011 3:00 am

Hi everyone

Great desktop environment! Thanks to all the contributers! I'm just facing a minor problem:
I'm having trouble setting the default window manager. Since I like to use the same DE on all my computers, I would like to use Lubuntu and Compiz on my faster one. I tried the following:
Changing Preferences> Desktop Session Settings> Advanced Options> Window Manager to
Code: Select all
compiz

and then to
Code: Select all
compiz --replace

but that didn't do the trick.

I changed the first line in /etc/xdg/lxsession/Lubuntu/desktop.conf and /etc/xdg/lxsession/Lubuntu-Netbook/desktop.conf to
Code: Select all
window_manager=compiz

(the one in the first file allready looked like that; because of the Desktop Settings, I suppose)

When I start up, still Openbox is loaded as WM. I did a kind of hacky workaround with a shell script. It works, but takes a little more time and is not really elegant. What did I miss/do wrong?
Let me know if you need any futher information or if this isn't the right place for questions about Lubuntu. Every answer is greatly appreciated.
Fejodor
 
Posts: 2
Joined: Sat Oct 15, 2011 2:40 am

Re: Problem changing window manager  Topic is solved

Postby rockdoctor » Mon Oct 17, 2011 12:02 am

Not sure about Lubuntu, but on my system (Fedora LXDE spin) both lxsession-edit (the Advanced Options tab) and ~/.config/lxsession/LXDE/desktop.conf both show the wm as openbox-lxde. Interestingly, changing the wm in lxsession-edit does not change the wm in ~/.config/lxsession/LXDE/desktop.conf.
Geology - It's not rocket science, it's rock science!
rockdoctor
 
Posts: 116
Joined: Tue Nov 11, 2008 5:51 pm

Re: Problem changing window manager

Postby Fejodor » Tue Oct 18, 2011 3:38 pm

Thanks a lot! That was the hint I needed.

I got two folders in .config/lxsession, each containing a desktop.config file. One folder called LXDE, where in desktop.config already compiz was defined as window manager (probably again because of desktop session settings) and one called Lubuntu, where still Openbox was selected. Changed the second one to Compiz, now everything is working as it should.

To me, this seems a bit confusing. I'm thinking about doing a Ubuntu minimal installation with LXDE. Those Ubuntu remixes don't seem to be very intuitive. But that's a different thing. The problem is solved.
Fejodor
 
Posts: 2
Joined: Sat Oct 15, 2011 2:40 am


Return to LXSession (Lite)

Who is online

Users browsing this forum: No registered users and 1 guest

cron