play sound at login

Please post all general support questions for LXDE here.

play sound at login

Postby jolato » Sat Jul 31, 2010 10:09 pm

After a lot of testing and searching for a solution to play a sound at login, I found a solution, however it needs some polish. When I login I managed to start audacious play an ogg file, but before that there are some other system-like sounds played.

My command I put in /etc/xdg/lxsession/LXDE/autostart

In preferences I disabled the login sound (preferences - login screen - play deselect login sound)

Where are the system sounds coming from ? Could be from the gnome session manager ? :?:
jolato
 
Posts: 2
Joined: Sat Jul 31, 2010 10:03 pm

Re: play sound at login

Postby maces » Sun Aug 01, 2010 1:54 pm

Hi,

LXDE doesn't play any sounds on login. If there are sounds, they are added by your distro. Btw, what distro are you using?

maces
maces
 
Posts: 503
Joined: Sat Oct 25, 2008 7:04 pm

Re: play sound at login

Postby jolato » Sun Aug 01, 2010 4:54 pm

In ~/.config/autostart/ you can put an *.desktop file that contains:

[Desktop Entry]
Encoding=UTF-8
Name= Connect
Comment=Checks internet connectivity
Exec=/usr/bin/audacious /home/familie/.config/autostart/audio.sh >> log 2>&1
Terminal=true

That's how you start programs automatically under LXDE

My gnome session did this through the preferences - Startup Apps - Gnome play sound but I turned that off.
jolato
 
Posts: 2
Joined: Sat Jul 31, 2010 10:03 pm

Re: play sound at login

Postby maces » Mon Aug 02, 2010 3:20 pm

If the *.desktop file is still there after disabling the sound in gnome, you should move or delete it.

maces
maces
 
Posts: 503
Joined: Sat Oct 25, 2008 7:04 pm


Return to General Help

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest