Keyboard Shortcut for Application Menu - How?

Please post all general support questions for LXDE here.

Keyboard Shortcut for Application Menu - How?

Postby DirtyDawg » Tue Jul 12, 2011 4:10 pm

Hello, i would like to know if there is a keyboard shortcut to launch the main menu,
i am using Mint 11 with LXDE added, i downloaded something called obkey to assign it
but i dont know what to put in it, i can add a shortcut using that with an execute tag,
but what would i type to launch the main menu as if i had pressed the "Menu" button?

Thanks.
DirtyDawg
 
Posts: 1
Joined: Sun Jul 10, 2011 1:06 pm

Re: Application Menu How?

Postby mike555 » Thu Aug 04, 2011 3:42 pm

I think the command is;
Code: Select all
lxpanelctl menu
mike555
 
Posts: 3
Joined: Wed Aug 03, 2011 1:59 am

Re: Application Menu How?

Postby amjjawad » Mon Sep 19, 2011 8:14 pm

mike555 wrote:I think the command is;
Code: Select all
lxpanelctl menu


Code: Select all
lxpanelctl menu


Running this command in LXTerminal will open/start the menu. I think the OP is asking about how to assign a shortcut to open the menu.
amjjawad
Start Ubuntu

Test Machine: ASUS F3F Laptop - Intel Core Duo T2350 @ 1.86GHz with 489MB RAM
amjjawad
 
Posts: 314
Joined: Mon Aug 29, 2011 2:51 am

Re: Application Menu How?

Postby rockdoctor » Mon Sep 19, 2011 9:33 pm

adding the following to ~/.config/openbox/lxde-rc.xml worked for me (shortcut is Alt-m)
Code: Select all
    <!-- ****************************************************** -->
    <keybind key="A-m">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>
    <!-- ****************************************************** -->
Geology - It's not rocket science, it's rock science!
rockdoctor
 
Posts: 116
Joined: Tue Nov 11, 2008 5:51 pm

Re: Application Menu How?

Postby amjjawad » Tue Sep 20, 2011 7:17 am

rockdoctor wrote:adding the following to ~/.config/openbox/lxde-rc.xml worked for me (shortcut is Alt-m)
Code: Select all
    <!-- ****************************************************** -->
    <keybind key="A-m">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>
    <!-- ****************************************************** -->


rockdoctor, I see lots of lines inside that file so where exactly shall I add the above code? I'd like to test that myself and see what will happen :)
Does it matter where to place it inside that file?
amjjawad
Start Ubuntu

Test Machine: ASUS F3F Laptop - Intel Core Duo T2350 @ 1.86GHz with 489MB RAM
amjjawad
 
Posts: 314
Joined: Mon Aug 29, 2011 2:51 am

Re: Application Menu How?

Postby LXNevermind » Tue Sep 20, 2011 3:13 pm

For me the best is the end of keyboard section, becouse it's easy to find;) but you can place it anywhere you want in keyboard section.
LXNevermind
 
Posts: 34
Joined: Sat Sep 10, 2011 12:31 pm

Re: Application Menu How?

Postby amjjawad » Tue Sep 20, 2011 4:39 pm

LXNevermind wrote:For me the best is the end of keyboard section, becouse it's easy to find;) but you can place it anywhere you want in keyboard section.


Code: Select all
<keyboard><chainQuitKey>C-g</chainQuitKey><!-- Keybindings for desktop switching --><keybind key="C-A-Left"><action name="DesktopLeft"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="C-A-Right"><action name="DesktopRight"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="C-A-Up"><action name="DesktopUp"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="C-A-Down"><action name="DesktopDown"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="S-A-Left"><action name="SendToDesktopLeft"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="S-A-Right"><action name="SendToDesktopRight"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="S-A-Up"><action name="SendToDesktopUp"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="S-A-Down"><action name="SendToDesktopDown"><dialog>no</dialog><wrap>no</wrap></action></keybind><keybind key="W-F1"><action name="Desktop"><desktop>1</desktop></action></keybind><keybind key="W-F2"><action name="Desktop"><desktop>2</desktop></action></keybind><keybind key="W-F3"><action name="Desktop"><desktop>3</desktop></action></keybind><keybind key="W-F4"><action name="Desktop"><desktop>4</desktop></action></keybind><keybind key="W-d"><action name="ToggleShowDesktop"/></keybind><!-- Keybindings for windows --><keybind key="A-F4"><action name="Close"/></keybind><keybind key="A-Escape"><action name="Lower"/><action name="FocusToBottom"/><action name="Unfocus"/></keybind><keybind key="A-space"><action name="ShowMenu"><menu>client-menu</menu></action></keybind><!-- Keybindings for window switching --><keybind key="A-Tab"><action name="NextWindow"/></keybind><keybind key="A-S-Tab"><action name="PreviousWindow"/></keybind><keybind key="C-A-Tab"><action name="NextWindow"><panels>yes</panels><desktop>yes</desktop></action></keybind><!-- Keybindings for running applications --><keybind key="W-e"><action name="Execute"><startupnotify><enabled>true</enabled><name>PCManFM</name></startupnotify><command>pcmanfm</command></action></keybind><!--keybindings for LXPanel --><keybind key="W-r"><action name="Execute"><command>lxpanelctl run</command></action></keybind><keybind key="A-F2"><action name="Execute"><command>lxpanelctl run</command></action></keybind><keybind key="C-Escape"><action name="Execute"><command>lxpanelctl menu</command></action></keybind><keybind key="F11"><action name="ToggleFullscreen"/></keybind><!-- Launch Task Manager with Ctrl+Alt+Del --><keybind key="A-C-Delete"><action name="Execute"><command>lxtask</command></action></keybind><!-- Fast access to Terminal --><keybind key="C-A-T"><action name="Execute"><command>lxterminal</command></action></keybind><!-- Fast access to filemanager --><keybind key="C-A-D"><action name="Execute"><startupnotify><enabled>true</enabled><name>PCManFM</name></startupnotify><command>pcmanfm</command></action></keybind><!-- Keybinding for PrintScreen Key --><keybind key="Print"><action name="Execute"><execute>scrot</execute></action></keybind><keybind key="A-Print"><action name="Execute"><execute>scrot -s</execute></action></keybind><!-- Keybinding for Volume management -->
    <keybind key="XF86AudioRaiseVolume">
      <action name="Execute">
          <command>amixer -q sset Master 3%+</command>
      </action>
    </keybind>

    <keybind key="XF86AudioLowerVolume">
      <action name="Execute">
          <command>amixer -q sset Master 3%-</command>
      </action>
    </keybind>

    <keybind key="XF86AudioMute">
      <action name="Execute">
          <command>amixer -q sset Master toggle</command>
      </action>
    </keybind>

    <keybind key="XF86WWW">
      <action name="Execute">
          <command>x-terminal-emulator</command>
      </action>
    </keybind>

    <keybind key="XF86Calculator">
      <action name="Execute">
          <command>galculator</command>
      </action>
    </keybind>

    <keybind key="XF86MyComputer">
      <action name="Execute">
          <command>pcmanfm</command>
      </action>
    </keybind>

    <keybind key="XF86Terminal">
      <action name="Execute">
          <command>x-terminal-emulator</command>
      </action>
    </keybind>

   <!-- Keybindings for Multimedia Keys and LCD Backlight (alternative when not using gnome-power-manager or xfce4-volumed)
     <keybind key="C-F7">
      <action name="Execute">
        <execute>sleep 2;xset dpms force off</execute>
      </action>
    </keybind>
     <keybind key="C-F10">
      <action name="Execute">
        <execute>xbacklight -dec 10</execute>
      </action>
    </keybind>
     <keybind key="C-F11">
      <action name="Execute">
        <execute>xbacklight -inc 10</execute>
      </action>
    </keybind> -->
        <keybind key="A-m">
          <action name="Execute">
            <command>lxpanelctl menu</command>
          </action>
        </keybind>
  </keyboard>


It didn't work for me. I'll check what's wrong.

Edit:
Now, I got an error msg (after I logged out and logged in again)
Great ... I don't even use Shortcuts for LXDE ... I just did that to test that on my machine. Need to fix that later. Don't have time for this :/
Attachments
Screenshot-3.png
Screenshot-3.png (51.05 KiB) Viewed 1095 times
amjjawad
Start Ubuntu

Test Machine: ASUS F3F Laptop - Intel Core Duo T2350 @ 1.86GHz with 489MB RAM
amjjawad
 
Posts: 314
Joined: Mon Aug 29, 2011 2:51 am

Re: Application Menu How?

Postby LXNevermind » Wed Sep 21, 2011 12:11 pm

Delete "-->" ;) and try again, if that doesnt work tell us what do you have in those 2 lines that error is about;)

EDIT: you can also try command
Code: Select all
lxtermianl -e lxpanelctl menu
instead of
Code: Select all
lxpanelctl menu
but I dont think itll be necessary.
LXNevermind
 
Posts: 34
Joined: Sat Sep 10, 2011 12:31 pm

Re: Application Menu How?

Postby amjjawad » Wed Sep 21, 2011 1:56 pm

LXNevermind wrote:Delete "-->" ;) and try again, if that doesnt work tell us what do you have in those 2 lines that error is about;)

EDIT: you can also try command
Code: Select all
lxtermianl -e lxpanelctl menu
instead of
Code: Select all
lxpanelctl menu
but I dont think itll be necessary.


If I remember correctly, I removed that "-->" after I posted but I'll check that ... I'm using another machine right now.
I love trying/testing so I don't mind messing my system up. After all, one can't learn how to fix the system unless he/she breaks it :D

Keep it up LXNevermind, I'm glad to see a new active member here :)

Edit: I just checked and it seems that I removed that code from my lubuntu-rc.xml file but the error msg is still showing up. My bad, I should have made a copy of that file as a backup before testing :/
amjjawad
Start Ubuntu

Test Machine: ASUS F3F Laptop - Intel Core Duo T2350 @ 1.86GHz with 489MB RAM
amjjawad
 
Posts: 314
Joined: Mon Aug 29, 2011 2:51 am

Re: Keyboard Shortcut for Application Menu - How?

Postby amjjawad » Wed Sep 21, 2011 5:03 pm

Ok, I fixed the issue. I copied and paste the content of "Keyboard" section from this topic/thread to my file, saved it, logged out and it works just fine. Now, I guess it's time to re-do the test :D
amjjawad
Start Ubuntu

Test Machine: ASUS F3F Laptop - Intel Core Duo T2350 @ 1.86GHz with 489MB RAM
amjjawad
 
Posts: 314
Joined: Mon Aug 29, 2011 2:51 am

Next

Return to General Help

Who is online

Users browsing this forum: Google [Bot] and 1 guest