Error with LXAppearance and gtk icon theme

The standard theme switcher of LXDE - http://wiki.lxde.org/en/LXAppearance

Error with LXAppearance and gtk icon theme

Postby carlosmtron » Wed Feb 24, 2010 12:56 am

Hello. I have a problem trying to configure the icons. When starting my session in LXDE, I get the familiar message "GTK + icon theme is not properly set". I tried to fix the file ~ /.gtkrc-2.0 manually, but did not get any better. Then I tried using LXAppearance, but icons and themes did not change, even though I sensed that I have installed the icons and themes. Running LXAppearance get this output in a terminal:
Code: Select all
carlos@NCC1701:~$ lxappearance
(lxappearance:9910): Gtk-CRITICAL **: gtk_widget_ref: assertion `GTK_IS_WIDGET (widget)' failed
(lxappearance:9910): Gtk-CRITICAL **: gtk_widget_ref: assertion `GTK_IS_WIDGET (widget)' failed
(lxappearance:9910): Gtk-CRITICAL **: gtk_widget_ref: assertion `GTK_IS_WIDGET (widget)' failed
(lxappearance:9910): Gtk-CRITICAL **: gtk_widget_ref: assertion `GTK_IS_WIDGET (widget)' failed
(lxappearance:9912): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
(lxappearance:9914): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
carlos@NCC1701:~$


This is my ~/gtkrc-2.0
Code: Select all
carlos@NCC1701:~$ cat .gtkrc-2.0
# DO NOT EDIT!  This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine

gtk-theme-name="Raleigh"
gtk-icon-theme-name="nuoveXT2"
gtk-font-name="Sans 10"
gtk-toolbar-style=3
gtk-cursor-theme-name="(null)"
gtk-cursor-theme-size=16
include "/home/carlos/.gtkrc-2.0.mine"
carlos@NCC1701:~$


Can you help solve the problem? I can't change or icons or the theme. It may help to know that I use Debian testing and was originally installed XFCE. While I have XFCE, could change the theme, but not the icons since I got the same error.

Please, excuse if my English very bad.

Carlos
carlosmtron
 
Posts: 5
Joined: Wed Feb 24, 2010 12:19 am

Re: Error with LXAppearance and gtk icon theme

Postby carlosmtron » Sat Feb 27, 2010 6:53 pm

Searching in my computer I discovered that the problem is that having installed XFCE before, although before uninstalling the desktop environment was the error. I think this because the file /etc/xdg/openbox/autostart.sh is:
Code: Select all
NCC1701:/etc/xdg/openbox# cat autostart.sh
# This shell script is run before Openbox launches.
# Environment variables set here are passed to the Openbox session.

# Set a background color
BG=""
if which hsetroot >/dev/null; then
    BG=hsetroot
else
    if which esetroot >/dev/null; then
   BG=esetroot
    else
   if which xsetroot >/dev/null; then
       BG=xsetroot
   fi
    fi
fi
test -z $BG || $BG -solid "#303030"

# D-bus
if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
       eval `dbus-launch --sh-syntax --exit-with-session`
fi

# Make GTK apps look and behave how they were set up in the gnome config tools
if test -x /usr/libexec/gnome-settings-daemon >/dev/null; then
  /usr/libexec/gnome-settings-daemon &
elif which gnome-settings-daemon >/dev/null; then
  gnome-settings-daemon &
# Make GTK apps look and behave how they were set up in the XFCE config tools
elif which xfce-mcs-manager >/dev/null; then
  xfce-mcs-manager n &
fi

# Preload stuff for KDE apps
if which start_kdeinit >/dev/null; then
  LD_BIND_NOW=true start_kdeinit --new-startup +kcminit_startup &
fi

# Run XDG autostart things.  By default don't run anything desktop-specific
# See xdg-autostart --help more info
DESKTOP_ENV=""
if which /usr/lib/openbox/xdg-autostart >/dev/null; then
  /usr/lib/openbox/xdg-autostart $DESKTOP_ENV
fi


I think this may help. For my part, I'll see if I can fix it. Do you think I can provide some other file? Can someone show me his autostart.sh for me to guide me?
Thank you very much
Carlos
carlosmtron
 
Posts: 5
Joined: Wed Feb 24, 2010 12:19 am

Re: Error with LXAppearance and gtk icon theme

Postby carlosmtron » Sun Feb 28, 2010 1:19 pm

I solved the problem of the icons. I discovered that in the ~ /.config/lxde/config had these lines:

snet/ThemeName = Raleigh
snet/IconThemeName = nuoveXT2

that previously had the theme and icons when I was XFCE. I put the name and theme I have in ~ /.gtkrc-2.0

I did the same with the file /etc/xdg/lxsession/LXDE/desktop.conf
Then restart my session and everything went well. I no longer appeared the poster GTK + icon theme is not properly set. :)

However LXAppearance still returns the same error and when I try to change icons or themes from there do not listen to me. The program also shows me the preview window with the theme I choose.

Greetings

Carlos
carlosmtron
 
Posts: 5
Joined: Wed Feb 24, 2010 12:19 am


Return to LXAppearance

Who is online

Users browsing this forum: No registered users and 1 guest