Compiz - window borders disappear when running Compiz

Please post all general support questions for LXDE here.

Compiz - window borders disappear when running Compiz

Postby travlemon » Thu Mar 10, 2011 7:37 pm

Hello Everyone,

I've been Googling this issue, and can't seem to find a solution that works for my machine. I installed Lubuntu 10.10 on a Thinkpad R40. The only issue I've been having with the LXDE environment is that I can't seem to get Compiz to work properly.

I've installed Compiz, its settings manager, the fusion icon, and the Emerald window decorator. After using the fusion icon to make Compiz my window manager and Emerald my decorator, I run this in the terminal:
Code: Select all
compiz --replace

When I do this, the window borders disappear and I get a strange terminal window that pops up in the top left hand portion of the screen, and doesn't receive any input from my keyboard. It'll go away when I hit CTRL+C to kill the Compiz command.

Also, I generated xorg.conf (I understand 10.10 doesn't include it by default anymore?) via the command:
Code: Select all
sudo Xorg -configure


It generated xorg.conf.new in my home folder, so I renamed it to xorg.conf and moved it to /etc/X11.

At the suggestion of a Compiz thread I found, I edited all values for all instances of "Depth" in the "Screen" section to be 24. This apparently worked for quite a few other people, but not quite for me. Is there another way to make sure I'm forcing 24 bit mode?

One last note: the graphics card in the laptop, as reported by Lubuntu, is an ATI Radeon Mobility 7500. I had the regular Gnome version of Ubuntu on it and the effects ran quite smooth for it being an older laptop, so that gives me hope that I can get this working.

Any help on this one is much appreciated, I love my Compiz!
travlemon
 
Posts: 3
Joined: Thu Mar 10, 2011 7:20 pm

Re: Compiz - window borders disappear when running Compiz

Postby phillipe » Tue Mar 15, 2011 6:02 am

Travlemon, to solve this problem, you have to open Compiz Config Manager >> Window Decoration and in the Command field add this: emerald --replace

Only This! ;)
==> Phillipe Smith ( SmithuX ) <==
Email: phillipe@archlinux.com.br
WebSite: http://www.smithux.com
phillipe
 
Posts: 41
Joined: Mon Apr 27, 2009 5:12 pm

Re: Compiz - window borders disappear when running Compiz

Postby travlemon » Tue Mar 15, 2011 9:56 am

phillipe wrote:Travlemon, to solve this problem, you have to open Compiz Config Manager >> Window Decoration and in the Command field add this: emerald --replace

Only This! ;)


Hello, thanks for responding! I have tried that solution already, and still it seems not to like Compiz. Just to make sure it's not simply a video card issue, I installed a Lubuntu guest on VirtualBox, hosting from a totally different PC. Once I verified that guest additions were properly installed, I tried repeating all of the discussed steps to get Compiz working. Still, it has the exact issue even with a totally different video interface.

I think I may just throw in the towel on it. I have no problem reinstalling between distros on that laptop, it's just a web browser. I noticed that Ubuntu based distros, that have Openbox as the desktop, seem to let me configure and run Compiz perfectly. One thing that confuses me though... Distrowatch.org reports Peppermint OS, for example, to have Openbox as its desktop. Upon logging in, it seems identical to LXDE. Not sure what that's about!
travlemon
 
Posts: 3
Joined: Thu Mar 10, 2011 7:20 pm

Re: Compiz - window borders disappear when running Compiz

Postby rockdoctor » Fri Mar 25, 2011 11:58 am

I'm having a similar problem with Compiz/Emerald on Fedora Rawhide. However, Compiz/Emerald work just fine on Fedora 15
Geology - It's not rocket science, it's rock science!
rockdoctor
 
Posts: 116
Joined: Tue Nov 11, 2008 5:51 pm


Return to General Help

Who is online

Users browsing this forum: No registered users and 1 guest