[gelöst] Datumsformat in PCManFM

The German language LXDE Forum. Das deutschsprachige LXDE-Forum.

Moderator: maces

Askalex
Posts: 13
Joined: Wed Oct 10, 2018 1:44 pm

[gelöst] Datumsformat in PCManFM

Postby Askalex » Thu Oct 11, 2018 10:29 am

Hallo,
ich nutzte LXDE unter Debian 9. und würde gern das Datumsformat in PCManFM auf das gewohnte dd.mm.YYYY umstellen. Kann aber nichts dazu finden.

Aus dem was ich im englischen Forum gefunden habe werd ich nicht schlau: in Datei
.bashrc (in User)

Code: Select all

export LC_TIME=de_DE.UTF-8

Einfügen. Das habe ich gemacht, hilf nicht. Bin auch nicht sehr vertraut mit all den Linux Inneren :|
Danke vorab
Last edited by Askalex on Sat Nov 10, 2018 11:44 am, edited 1 time in total.

drooly
Posts: 546
Joined: Mon Apr 08, 2013 6:45 am

Re: Datumsformat in PCManFM

Postby drooly » Fri Oct 12, 2018 5:35 pm

nein, ~/.bashrc ist nicht die richtige datei.
versuch's mal mit ~/.bash_profile oder ~/.profile.

und hast du auch versucht es im panel selbst einzustellen?
also bei mir steht da "Clock format: %R" - da könntest du z.b.

Code: Select all

%-d.%-m.%Y
einfügen.
(quelle: "man date")

welche locale hast du denn eingestellt für dein system? nicht de?

zeig uns mal

Code: Select all

locale

Askalex
Posts: 13
Joined: Wed Oct 10, 2018 1:44 pm

Re: Datumsformat in PCManFM

Postby Askalex » Sat Oct 13, 2018 5:24 pm

und hast du auch versucht es im panel selbst einzustellen?
also bei mir steht da "Clock format: %R" - da könntest du z.b.

Welches Panel meinst du? Ich habe in den Einstellungen von PCManFM geschaut, es gibt unter 'Erweitert' ein Feld Formatierungs Befehl (unter Terminal Emulator), da hab das Format %-d.%-m.%Y (mit und ohne 'Clock format:') eingetragen, bewirkt aber auch nichts.

Code: Select all

locale
locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden
LANG=de_AT.UTF-8
LANGUAGE=de_AT:de
LC_CTYPE="de_AT.UTF-8"
LC_NUMERIC="de_AT.UTF-8"
LC_TIME=de_DE.UTF-8
LC_COLLATE="de_AT.UTF-8"
LC_MONETARY="de_AT.UTF-8"
LC_MESSAGES="de_AT.UTF-8"
LC_PAPER="de_AT.UTF-8"
LC_NAME="de_AT.UTF-8"
LC_ADDRESS="de_AT.UTF-8"
LC_TELEPHONE="de_AT.UTF-8"
LC_MEASUREMENT="de_AT.UTF-8"
LC_IDENTIFICATION="de_AT.UTF-8"
LC_ALL=

Rex Bouwense
Posts: 1022
Joined: Sat Aug 27, 2011 5:44 pm
Location: Sierra Vista, Arizona USA
Contact:

Re: Datumsformat in PCManFM

Postby Rex Bouwense » Sun Oct 14, 2018 7:43 pm

What drooly was referring to was the Lxpanel at the bottom of your screen. Merely right click on the time there and select "digital clock settings". Next to clock settings place your desired setting. See https://www.foragoodstrftime.com/ to build your date time formatting.

Was Drogy meinte, war das Lxpanel am unteren Bildschirmrand. Klicken Sie einfach mit der rechten Maustaste auf die Uhrzeit und wählen Sie "Digitaluhreinstellungen". Stellen Sie neben den Uhreinstellungen die gewünschte Einstellung ein. Unter https://www.foragoodstrftime.com/ können Sie Ihre Formatierung für die Datumszeit erstellen.
Rex
Lubuntu 18.04

Askalex
Posts: 13
Joined: Wed Oct 10, 2018 1:44 pm

Re: Datumsformat in PCManFM

Postby Askalex » Mon Oct 15, 2018 7:03 pm

Danke für den Tip. Das hat aber keinen Einfluss auf PCManFM.

PS: ich habe in der .profile

Code: Select all

export LC_TIME=de_DE.UTF-8
eingefügt. hat aber auch nichts gebracht. Eine /.bash_profile gibts bei mir nicht.

Askalex
Posts: 13
Joined: Wed Oct 10, 2018 1:44 pm

Re: Datumsformat in PCManFM

Postby Askalex » Mon Oct 22, 2018 8:23 am

PS: Hab da noch eine:

Code: Select all

bash: Warnung: setlocale: LC_TIME: Kann nicht die Locale ändern (de_DE.UTF-8): Datei oder Verzeichnis nicht gefunden

Aus Debian Menue > Anwendungen >Shells > Bash
(fehlt da eine Datei ? Wenn ja was muss drin stehen?)
(weiß nicht was dieses Terminal vom normalen unterscheidet, in dem ist es nicht)

drooly
Posts: 546
Joined: Mon Apr 08, 2013 6:45 am

Re: Datumsformat in PCManFM

Postby drooly » Mon Oct 22, 2018 7:06 pm

tut mir leid dass ich das mit dem panel verwechselt habe.

du kannst die locale nicht auf de_DE umstellen weil die nicht installiert ist.
sowas kannst du auf der debian wiki nachlesen.

was ist das Standard Zeitformat für de_AT? genau wie de_DE? Dann verstehe ich nicht warum es nicht auch so dargestellt wird.
es scheint für pcmanfm keine option zu geben das von hand einzustellen, also benutzt er das format was das system vorgibt.
gibt es da under den Systemeinstellungen ein programm um zeit/datum einzustellen?

Askalex
Posts: 13
Joined: Wed Oct 10, 2018 1:44 pm

Re: Datumsformat in PCManFM

Postby Askalex » Sun Nov 04, 2018 9:05 pm

es gibt im Menü Einstellungen 'Datum und Uhrzeit' aber da kann man auch nicht das Format ändern...

drooly
Posts: 546
Joined: Mon Apr 08, 2013 6:45 am

Re: Datumsformat in PCManFM

Postby drooly » Thu Nov 08, 2018 1:12 pm

drooly wrote:du kannst die locale nicht auf de_DE umstellen weil die nicht installiert ist.
sowas kannst du auf der debian wiki nachlesen.

ich hab's dir jetzt rausgesucht:
https://wiki.debian.org/Locale

Askalex
Posts: 13
Joined: Wed Oct 10, 2018 1:44 pm

Re: Datumsformat in PCManFM

Postby Askalex » Sat Nov 10, 2018 11:43 am

Danke dir drooly, ich habs jetzt.
Ich hatte irgend wo gelesen das in der Datei bashrc im user verzeichniss
'export LC_TIME=de_DE.UTF-8' eingetragen sein muss. Genau das war scheinbar falsch; da hab ich nachdem ich

Code: Select all

sudo dpkg-reconfigure locales
gemacht habe ein Fehlermemeldung bekommen.

Es muss NUR in der Datei /etc/locale.gen 'de_DE.UTF-8 UTF-8' eingetragen sein, (Raute davor entfernen).
Dann nochmal im Terminal 'sudo dpkg-reconfigure locales' und reboot. Danach wars okay.

Die letzte Terminal Meldung dabei war:

Code: Select all

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "de_AT:de",
   LC_ALL = (unset),
   LANG = "de_DE.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales (this might take a while)...
  de_DE.UTF-8... done
Generation complete.

Der erste Teil, die perl warning kam solange wie 'export LC_TIME=de_DE.UTF-8' in bachrc eingetragen war...
Der Formatierungs Befehl in den erweiterten Einstellungen von PCmanFM hat darauf keinen Einfluss.
Vielleicht kam das Durcheinander weil ich bei der Installation von System Wien angegeben habe...
BTW eine Datei de_DE gibt es in '/usr/share/i18n/locales'
Ich habe keine Ahnung wie all diese datein ineinander greifen... :roll: :)


Return to “German language LXDE Forum / Deutschsprachiges LXDE Forum”

Who is online

Users browsing this forum: No registered users and 1 guest