LXmusic 無法編譯成功

This is the LXDE forum for Chinese users. Feel free to ask here in Chinese.
這是 LXDE 的中文討論區,歡迎在本討論區使用中文表達。
nelsonchung
Posts: 1
Joined: Tue Sep 16, 2008 1:40 am

LXmusic 無法編譯成功

Postby nelsonchung » Tue Jun 09, 2009 4:30 pm

以下是我的編譯過程
nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$ ./autogen.sh
+ [ x != x ]
+ aclocal
+ autoheader
+ AUTOMAKE=automake-1.10 libtoolize -c --automake --force
+ AUTOMAKE=automake-1.10 intltoolize -c --automake --force
+ automake-1.10 --add-missing --copy --include-deps
configure.in:4: installing `./install-sh'
configure.in:4: installing `./missing'
data/Makefile.am:25: `%'-style pattern rules are a GNU make extension
src/Makefile.am: installing `./depcomp'
+ autoconf
+ cp -f /usr/share/automake-1.10/mkinstalldirs .
+ rm -rf autom4te.cache

nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking whether NLS is requested... yes
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.0
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LXMUSIC... configure: error: Package requirements (gtk+-2.0 >= 2.14.0
gmodule-export-2.0 >= 2.0
xmms2-client >= 0.6
xmms2-client-glib >= 0.6) were not met:

No package 'xmms2-client' found
No package 'xmms2-client-glib' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LXMUSIC_CFLAGS
and LXMUSIC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$ sudo apt-get install xmms2-client
[sudo] password for nelsonchung:
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
E: 無法找到套件 xmms2-client
nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$ sudo apt-get install xmms2-client-glib
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
E: 無法找到套件 xmms2-client-glib
nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$

找不到套件
裝裝看
nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$ sudo apt-get install xmms2-client-cli
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
下列的額外套件將被安裝:
libxmmsclient-glib1 libxmmsclient4
建議套件:
xmms2-core
下列【新】套件將會被安裝:
libxmmsclient-glib1 libxmmsclient4 xmms2-client-cli
升級 0 個,新安裝 3 個,移除 0 個,有 0 個未被升級。
需要下載 98.8kB 的套件檔。
此操作完成之後,會多佔用 389kB 的磁碟空間。
是否繼續進行 [Y/n]?y
下載:1 http://tw.archive.ubuntu.com jaunty/universe libxmmsclient4 0.5DrLecter-2ubuntu3 [46.5kB]
下載:2 http://tw.archive.ubuntu.com jaunty/universe libxmmsclient-glib1 0.5DrLecter-2ubuntu3 [12.2kB]
下載:3 http://tw.archive.ubuntu.com jaunty/universe xmms2-client-cli 0.5DrLecter-2ubuntu3 [40.2kB]
取得 98.8kB 用了 2s (34.8kB/s)
選中了曾被取消選擇的套件 libxmmsclient4。
(正在讀取資料庫 ... 系統目前總共安裝有 138158 個檔案和目錄。)
正在解壓縮 libxmmsclient4 (從 .../libxmmsclient4_0.5DrLecter-2ubuntu3_i386.deb) ...
選中了曾被取消選擇的套件 libxmmsclient-glib1。
正在解壓縮 libxmmsclient-glib1 (從 .../libxmmsclient-glib1_0.5DrLecter-2ubuntu3_i386.deb) ...
選中了曾被取消選擇的套件 xmms2-client-cli。
正在解壓縮 xmms2-client-cli (從 .../xmms2-client-cli_0.5DrLecter-2ubuntu3_i386.deb) ...
Processing triggers for man-db ...
正在設定 libxmmsclient4 (0.5DrLecter-2ubuntu3) ...

正在設定 libxmmsclient-glib1 (0.5DrLecter-2ubuntu3) ...

正在設定 xmms2-client-cli (0.5DrLecter-2ubuntu3) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place


./configure
出現一樣的錯誤訊息
所以不是裝
xmms2-client-cli


Solution

sudo apt-get install libxmmsclient-dev libxmmsclient-glib-dev


nelsonchung@nelsonchung-laptop:~/Src/lxde/lxmusic$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking whether NLS is requested... yes
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.0
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LXMUSIC... configure: error: Package requirements (gtk+-2.0 >= 2.14.0
gmodule-export-2.0 >= 2.0
xmms2-client >= 0.6
xmms2-client-glib >= 0.6) were not met:

Requested 'xmms2-client >= 0.6' but version of xmms2-client is 0.5 DrLecter (git commit: b63ec5a270cfde0ae3d59c9b89d860b8650e430f-dirty)
Requested 'xmms2-client-glib >= 0.6' but version of xmms2-client-glib is 0.5 DrLecter (git commit: b63ec5a270cfde0ae3d59c9b89d860b8650e430f-dirty)

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LXMUSIC_CFLAGS
and LXMUSIC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

就無法在 make了
該如何處理呢

開發者都在ubuntu 還是在 debian 下開發?

Return to “Chinese LXDE Forum / LXDE 中文討論區”

Who is online

Users browsing this forum: No registered users and 1 guest