Panel's process is constantly writing to disk.

The standard panel of LXDE - http://wiki.lxde.org/en/LXPanel
nbds
Posts: 2
Joined: Tue Jul 26, 2016 4:56 pm

Panel's process is constantly writing to disk.

Postby nbds » Tue Jan 15, 2019 3:15 pm

Hello!

On Raspbian I have noticed that the panel's process regularly performs disk writes (every 60 seconds):

Code: Select all

$ pidstat -dl 600
Linux 4.14.79-v7+ (localhost)   01/15/2019  _armv7l_    (4 CPU)

03:11:53 PM   UID       PID   kB_rd/s   kB_wr/s kB_ccwr/s iodelay  Command
03:21:53 PM  1000      2195      0.00      0.13      0.00       0  lxpanel --profile LXDE-pi

03:21:53 PM   UID       PID   kB_rd/s   kB_wr/s kB_ccwr/s iodelay  Command
03:31:53 PM  1000      2195      0.00      0.13      0.00       0  lxpanel --profile LXDE-pi

03:31:53 PM   UID       PID   kB_rd/s   kB_wr/s kB_ccwr/s iodelay  Command
03:41:53 PM  1000      2195      0.00      0.13      0.00       0  lxpanel --profile LXDE-pi

03:41:53 PM   UID       PID   kB_rd/s   kB_wr/s kB_ccwr/s iodelay  Command
03:51:53 PM  1000      2195      0.00      0.13      0.00       0  lxpanel --profile LXDE-pi

03:51:53 PM   UID       PID   kB_rd/s   kB_wr/s kB_ccwr/s iodelay  Command
04:01:53 PM  1000      2195      0.00      0.13      0.00       0  lxpanel --profile LXDE-pi

04:01:53 PM   UID       PID   kB_rd/s   kB_wr/s kB_ccwr/s iodelay  Command
04:11:53 PM  1000      2195      0.00      0.13      0.00       0  lxpanel --profile LXDE-pi


Is there a way to prevent these writes from happening?

Thanks.


UPDATE: Upon further investigation it turns out that this seems to be a serious bug. "Wireless & wired network" component appends every 60 seconds a line

Code: Select all

"** Message: wlan0: Received scan results"


to ~/.cache/lxsession/LXDE-pi/run.log file. Starting the panel with "--log 0" parameter doesn't change this behaviour.

drooly
Posts: 502
Joined: Mon Apr 08, 2013 6:45 am

Re: Panel's process is constantly writing to disk.

Postby drooly » Wed Jan 16, 2019 8:21 pm

why is that such a big problem?
maybe it helps if you link ~/.cache/lxsession/LXDE-pi/run.log to /dev/null, or to a ramdisk if you want to prevent disk writes.
maybe it's enough if you start lxpanel with

Code: Select all

lxpanel 2>/dev/null


Return to “LXPanel”

Who is online

Users browsing this forum: No registered users and 2 guests