Help with hiding desktop panel

The standard panel of LXDE - http://wiki.lxde.org/en/LXPanel
Xeon5
Posts: 5
Joined: Thu May 11, 2017 9:58 am

Help with hiding desktop panel

Postby Xeon5 » Thu May 11, 2017 10:07 am

Hi guys, new here and new too Linux aswell.

I am currently working on a minimal desktop using Debian "Jessie" with LXDE and want to basically just have a desktop with short cuts and no panel/start bar.

Is it possible to set the panel to never show at the bottom via command line?

Rex Bouwense
Posts: 1001
Joined: Sat Aug 27, 2011 5:44 pm
Location: Sierra Vista, Arizona USA
Contact:

Re: Help with hiding desktop panel

Postby Rex Bouwense » Thu May 11, 2017 3:21 pm

Welcome to the LXDE forums. I moved your post to the LXPanel forum which is a more appropriate place for the topic. If you want to hide the LXPanel, right click any open space on the panel and choose Panel Settings. Open the last tab Advanced and check Minimize panel when not in use. That should do the trick.
Rex
Lubuntu 18.04

Xeon5
Posts: 5
Joined: Thu May 11, 2017 9:58 am

Re: Help with hiding desktop panel

Postby Xeon5 » Thu May 11, 2017 3:31 pm

Thanks Rex.

I need to do this via command line so that I can set it to be removed during a clean install. Since the post I have found out that I can just apt-get remove the lxpanel application which did the trick.

Not sure if it is linked but is it possible to disable the right click menu on the desktop as well?

drooly
Posts: 473
Joined: Mon Apr 08, 2013 6:45 am

Re: Help with hiding desktop panel

Postby drooly » Thu May 11, 2017 4:45 pm

Xeon5 wrote:Not sure if it is linked but is it possible to disable the right click menu on the desktop as well?

i think it is possible with a workaround:
a) right-click the desktop => desktop preferences => Advanced => CHECK show menus provided by window managers etc.
b) edit ~/.config/openbox/lxde-rc.xml and change

Code: Select all

     <mousebind button="Right" action="Press">
        <action name="ShowMenu">
          <menu>root-menu</menu>
        </action>
      </mousebind>

to

Code: Select all

     <mousebind button="Right" action="Press">
       <action name="Execute">
        <command>true</command>
      </action>
      </mousebind>

c) log out/in

not tested.

Xeon5
Posts: 5
Joined: Thu May 11, 2017 9:58 am

Re: Help with hiding desktop panel

Postby Xeon5 » Fri May 12, 2017 8:43 am

Thanks, I will test that and let you know :)

Xeon5
Posts: 5
Joined: Thu May 11, 2017 9:58 am

Re: Help with hiding desktop panel

Postby Xeon5 » Fri May 12, 2017 1:49 pm

So i tried the code mentioned above:

right click edit.png
right click edit.png (8.05 KiB) Viewed 3107 times


But when I right click it still shows the menu:

VirtualBox_jessie_default_1494594530447_90744_12_05_2017_14_47_42.png
VirtualBox_jessie_default_1494594530447_90744_12_05_2017_14_47_42.png (107.03 KiB) Viewed 3107 times

VirtualBox_jessie_default_1494594530447_90744_12_05_2017_14_48_46.png
VirtualBox_jessie_default_1494594530447_90744_12_05_2017_14_48_46.png (41.03 KiB) Viewed 3107 times


Any suggestions on how to disable these?

drooly
Posts: 473
Joined: Mon Apr 08, 2013 6:45 am

Re: Help with hiding desktop panel

Postby drooly » Sat May 13, 2017 1:13 pm

you missed step a):
drooly wrote:a) right-click the desktop => desktop preferences => Advanced => CHECK show menus provided by window managers etc.

Xeon5
Posts: 5
Joined: Thu May 11, 2017 9:58 am

Re: Help with hiding desktop panel

Postby Xeon5 » Mon May 15, 2017 11:39 am

Apologies for the confusion. I need to be able to do all this in command line as I want to create a restricted enviroment. Is there anyway to change that in the back end?

seppalta
Posts: 449
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Help with hiding desktop panel

Postby seppalta » Tue May 16, 2017 6:26 pm

Not sure what you are trying to do, but removing pcmanfm's role in controlling the desktop will get rid of the pcmanfm-right-click menu. To do this add the following entry to ~/.config/lxsession/LXDE/autostart, presuming you have lxsession and the full lxde desktop installed:

Code: Select all

@pcmanfm --desktop-off --profile LXDE


Otherwise, try adding the command to the Openbox autostart file.


Return to “LXPanel”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests