lxpanel moved to external monitor

The standard panel of LXDE - http://wiki.lxde.org/en/LXPanel
bucht
Posts: 3
Joined: Thu Feb 08, 2018 1:07 am

lxpanel moved to external monitor

Postby bucht » Thu Feb 08, 2018 1:22 am

In the panel setting, I set "monitor" to "1". But when I have an external monitor and locate it above or to the left of my laptop monitor, it seems that this external monitor becomes "monitor 1", and my panel moved to this external monitor. How can I fix the panel on my laptop monitor no matter where I locate external monitors?

drooly
Posts: 478
Joined: Mon Apr 08, 2013 6:45 am

Re: lxpanel moved to external monitor

Postby drooly » Fri Feb 09, 2018 7:42 am

you hacve to configure your monitors in such a way that the system knows which monitor is your chosen primary monitor.
you can do this with xrandr, but i recommend arandr. you can save your config, then make sure it gets executed on startup.

bucht
Posts: 3
Joined: Thu Feb 08, 2018 1:07 am

Re: lxpanel moved to external monitor

Postby bucht » Sun Feb 11, 2018 4:33 am

drooly wrote:you hacve to configure your monitors in such a way that the system knows which monitor is your chosen primary monitor.
you can do this with xrandr, but i recommend arandr. you can save your config, then make sure it gets executed on startup.


I tried both xrandr and arandr to set my laptop's LVDS monitor as primary. And the output of "xrandr" showed that the LVDS is indeed the primary one. But the panel still keeps moving to the left or upper screen no matter it is LVDS or VGA.

This is my screenshot of both screens. As you can see, the panel which is set to show on monitor 1 appears on the non-primary VGA screen above:


Image
Attachments
Screenshot from 2018-02-11 12-23-44.jpg
(248.42 KiB) Not downloaded yet

drooly
Posts: 478
Joined: Mon Apr 08, 2013 6:45 am

Re: lxpanel moved to external monitor

Postby drooly » Sun Feb 11, 2018 11:06 am

wild guess:
maybe you need to set it to monitor 0 (zero)?

bucht
Posts: 3
Joined: Thu Feb 08, 2018 1:07 am

Re: lxpanel moved to external monitor

Postby bucht » Mon Feb 12, 2018 12:20 am

drooly wrote:wild guess:
maybe you need to set it to monitor 0 (zero)?

there‘re only 3 options: 'All', '1', '2'. I tried each option but none of them is helpful...

seppalta
Posts: 449
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: lxpanel moved to external monitor

Postby seppalta » Mon Feb 12, 2018 4:23 am

Everything looks correct to the information in the image.(?) I see a vertical extended desktop screen layout and a panel preference calling for a "top" panel, which is what the picture shows. If you want the panel on the "bottom" of the extended desktop, you need to tick the bottom circle in Panel Preferences. For this kind of layout, lxpanel apparently gives you only 4 choices: top, bottom, left, right. If you choose right, then you need to align the right edge of the extended desktop, or you will lose the bottom part of your panel in empty space.


Return to “LXPanel”

Who is online

Users browsing this forum: No registered users and 2 guests