[Closed - fixed - but horrible] Problem with .desktop files with version 1.3.0

The dedicated forum for PCMan File Manager - http://wiki.lxde.org/en/PCManFM
peebee
Posts: 8
Joined: Wed Aug 28, 2013 3:24 pm

[Closed - fixed - but horrible] Problem with .desktop files with version 1.3.0

Postby peebee » Sat May 05, 2018 2:47 pm

[Fixed - but horrible] - see below - 1.3.0 is much fussier about the format of lxpanel configs than 1.2.5

With the new PcManFM / LibFM version 1.3.0, trying to activate a .desktop file brings up the dialog shown - clicking Execute and the .desktop file runs as would be expected.....anybody any ideas how to get rid of this unwanted dialog?

Screenshot.png
Screenshot.png (12.35 KiB) Viewed 226 times

Screenshot(1).png
Screenshot(1).png (16.71 KiB) Viewed 226 times
Last edited by peebee on Tue May 08, 2018 9:14 am, edited 2 times in total.

seppalta
Posts: 425
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Problem with .desktop files with version 1.3.0

Postby seppalta » Sat May 05, 2018 7:50 pm

Clicking any .desktop file set to execute will bring up the "execute" box, which is designed to offer you other choices than launching the app. Launching is available this way, but is not the normal way to launch applications. Usually apps are launched from menus, for which an "execute" box does not appear. So launching from menus, which should be present on your operating system, solves your problem. For more information, see http://lxlinux.com/#10.

peebee
Posts: 8
Joined: Wed Aug 28, 2013 3:24 pm

Re: Problem with .desktop files with version 1.3.0

Postby peebee » Sat May 05, 2018 9:24 pm

The problem is that the dialog box appears for entries in the lxpanel "application launch bar" and this is not wanted - it should behave like the menu.....

drooly
Posts: 435
Joined: Mon Apr 08, 2013 6:45 am

Re: Problem with .desktop files with version 1.3.0

Postby drooly » Sun May 06, 2018 4:00 pm

i'm pretty sure pcmanfm has an option in its preferences to always execute executables, or ask.

peebee wrote:The problem is that the dialog box appears for entries in the lxpanel "application launch bar" and this is not wanted - it should behave like the menu.....

that seems unlikely; did you create those yourself?
can you post the contents of the .desktop files in question?

peebee
Posts: 8
Joined: Wed Aug 28, 2013 3:24 pm

Re: Problem with .desktop files with version 1.3.0

Postby peebee » Sun May 06, 2018 4:12 pm

drooly wrote:that seems unlikely; did you create those yourself?
can you post the contents of the .desktop files in question?

No - they came with the apps in the panel - one is PcManFM itself - and clicking it brings up this unwanted executable file dialogue!!!

This all worked just fine in 1.2.5 - there seems to have been changes introduced in 1.3.0 which is treating .desktop files differently - and not nicely...... :(

seppalta
Posts: 425
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Problem with .desktop files with version 1.3.0

Postby seppalta » Mon May 07, 2018 4:42 am

What are the apps in the panel that bring up this box when clicked (besides pcmanfm)?

peebee
Posts: 8
Joined: Wed Aug 28, 2013 3:24 pm

FIXED Re: Problem with .desktop files with version 1.3.0

Postby peebee » Mon May 07, 2018 10:23 am

OK - fixed - would appear that 1.3.0 is much more fussy about the format of panel configs.....in particular whereas a full path entry to a .desktop file worked fine in 1.2.5, in 1.3.0 it needs to be just the name of the .desktop file with no path.

Thanks for the help - the questions did lead to uncovering the cause.

peebee
Posts: 8
Joined: Wed Aug 28, 2013 3:24 pm

Re: [Closed - fixed] Problem with .desktop files with version 1.3.0

Postby peebee » Tue May 08, 2018 9:14 am

Although this is fixed - the new behaviour of 1.3.0 with .desktop files is really horrible.....there should be separate preference settings for displaying the execution dialogue for .desktop files and shellscripts.....


Return to “PCManFM”

Who is online

Users browsing this forum: No registered users and 2 guests