Access NTFS partition via PCManFM

The dedicated forum for PCMan File Manager - http://wiki.lxde.org/en/PCManFM
xircon
Posts: 11
Joined: Sat Dec 06, 2008 5:41 pm

Access NTFS partition via PCManFM

Postby xircon » Sun Dec 07, 2008 4:50 pm

I get an error:




Image




Nautilus still works OK though.

xircon
Posts: 11
Joined: Sat Dec 06, 2008 5:41 pm

Re: Access NTFS partition via PCManFM

Postby xircon » Tue Dec 09, 2008 9:26 am

Last night I tried accessing my xp partition in pcmanfm as root and it works! very strange.

kgas
Posts: 45
Joined: Sat Dec 27, 2008 12:32 pm

Re: Access NTFS partition via PCManFM

Postby kgas » Thu Jan 01, 2009 1:07 pm

I also got similar error but it opens the folders and files all in read only mode.I have already changed ownership of NTFS partition to me and users. But pcmanfm sees the partition in root ownership only. I already installed ntfs-3g 1.5130-1.is it a bug or the way of pcmanfm?

trovador
Posts: 5
Joined: Sun Dec 28, 2008 4:45 pm

Re: Access NTFS partition via PCManFM

Postby trovador » Fri Jan 02, 2009 9:28 pm

Hi, I've got a problem with an external usb HD ntfs, I can read the files in read only mode as kgas. i've installed ntfs-3g but nothig.
I can only read does anybody know something about it ?

trovador
Posts: 5
Joined: Sun Dec 28, 2008 4:45 pm

Re: Access NTFS partition via PCManFM

Postby trovador » Sat Jan 03, 2009 12:46 am

I solved it by this line
$ echo ntfs-3g | sudo tee -a /etc/modules or this one
# echo ntfs-3g >> /etc/modules.
Becarefully #
>NO
>>YES

kgas
Posts: 45
Joined: Sat Dec 27, 2008 12:32 pm

Re: Access NTFS partition via PCManFM

Postby kgas » Sat Jan 03, 2009 5:26 pm

Hello trovador, which GNU/Linux are you using. In Arch linux I did not have any file named modules in /etc directory. creating the modules file with ntfs-3g entry also did not solve the issue in my case.

Edit: I found a work around. unmounting and then remounting the ntfs partition with rw option solved the problem in my case. This had also been discussed in Arch forum.
#sudo umount /dev/sdbX
#sudo mount -t ntfs-3g /dev/sdb1 /media/<mount-point> -o rw,users,auto

This can also be solved by setting the hal policy. In this thread you can check : viewtopic.php?f=5&t=11
Last edited by kgas on Thu Jan 08, 2009 4:27 pm, edited 1 time in total.

trovador
Posts: 5
Joined: Sun Dec 28, 2008 4:45 pm

Re: Access NTFS partition via PCManFM

Postby trovador » Sat Jan 03, 2009 9:01 pm

Hi kgas, I use Ubuntu,


Return to “PCManFM”

Who is online

Users browsing this forum: No registered users and 1 guest