Very curious problem - desktop shortcut to games pcmanfm

The dedicated forum for PCMan File Manager - http://wiki.lxde.org/en/PCManFM
jjjmmm10
Posts: 3
Joined: Fri Jul 04, 2014 9:32 am

Very curious problem - desktop shortcut to games pcmanfm

Postby jjjmmm10 » Fri Jul 04, 2014 9:48 am

Greetings! Great site and posters, thanks for the great work!

I have a very curious problem, hopefully someone can help. I need to create a desktop shortcut (debian wheezy lxde) that would link to "menu://applications/Games". I created the link using the following code:

[Desktop Entry]
Type=Application
Icon=applications-games
Name=Games
GenericName=Games
Comment=open games in PCManFM
Categories=FileManager;Utility;Core;GTK;
Exec=pcmanfm menu://applications/Games
StartupNotify=true
Terminal=false
MimeType=x-directory/normal;inode/directory;

Great, the link showed up and works great... or does it?? Well, the link works when it is created, but then the curious problem happens: if I reboot the machine, and (first thing) double click the "Games" shortcut, nothing happens, and PCManFM freezes (does not work when clicking on it). However, if I reboot the machine and double click first on the file manager (PCManFM) and then on the link "Games", all links work!! Funny, no??

I believe that some part of PCManFM needs to be initiated first before the link "Games" can work, but I was unable to figure this out.

Any suggestions/help would be greatly appreciated.

Thanks!

jjjmmm10
Posts: 3
Joined: Fri Jul 04, 2014 9:32 am

Re: Very curious problem - desktop shortcut to games pcmanfm

Postby jjjmmm10 » Mon Jul 07, 2014 6:57 pm

Anyone? Please?

jjjmmm10
Posts: 3
Joined: Fri Jul 04, 2014 9:32 am

Re: Very curious problem - desktop shortcut to games pcmanfm

Postby jjjmmm10 » Mon Jul 07, 2014 11:01 pm

:D Ok, I found a workaround:

First, create a new folder called "Games" in your home/username/ folder (or any other location you want).

Then, navigate to /usr/share/applications , select all game icons you want and then select edit>copy at the top of the window to to copy all icons to your new "Games" folder.

Then, create a blank file on desktop, save it as "Games", then open it with leafpad it and paste:

[Desktop Entry]
Type=Application
Icon=applications-games
Name=Games
GenericName=Games
Comment=open games in PCManFM
Categories=FileManager;Utility;Core;GTK;
Exec=pcmanfm /home/username/Games
StartupNotify=true
Terminal=false
MimeType=x-directory/normal;inode/directory;

Save the file and voila! It works and avoids the problems described in this thread.

Rex Bouwense
Posts: 966
Joined: Sat Aug 27, 2011 5:44 pm
Location: Sierra Vista, Arizona USA

Re: Very curious problem - desktop shortcut to games pcmanfm

Postby Rex Bouwense » Mon Jul 07, 2014 11:24 pm

Thank you for following up with a solution to your own problem. Answers are always welcome here, but too often when an OP solves the problem, they fail to close the loop. We are greatful that your problem is solved. Stick around if you have the time to provide assistance to others. We are a small forum so all help is good.
Rex
Lubuntu 16.04

LStranger
Posts: 49
Joined: Sat Nov 05, 2011 5:48 pm

Re: Very curious problem - desktop shortcut to games pcmanfm

Postby LStranger » Fri Aug 22, 2014 9:41 pm

You don't need to write any files on desktop - you either drag the Games folder from within PCManFM to desktop, or select that folder and use 'Edit'->'Create Link...' option in the PCManFM main menu. Either way you will get a shortcut on your desktop which can be opened instantly as any other folder on desktop. :)

In case you are curious and want to create the shortcut manually in some text editor, it's content would be much simpler than you wrote above but:

Code: Select all

[Desktop Entry]
Type=Link
Icon=applications-games
Name=Games
URL=menu://applications/Games


Return to “PCManFM”

Who is online

Users browsing this forum: No registered users and 2 guests