mount devtmpfs on ~/test cause device item in side pane?

The dedicated forum for PCMan File Manager - http://wiki.lxde.org/en/PCManFM
lbuiyzxl
Posts: 7
Joined: Wed Aug 09, 2017 1:29 pm

mount devtmpfs on ~/test cause device item in side pane?

Postby lbuiyzxl » Thu Feb 22, 2018 7:14 am

mount devtmpfs on ~/test cause device item in side pane?
I can't found anything by 'sudo udisksctl monitor'
How do I avoid such helpless devtmpfs item in side pane?

seppalta
Posts: 441
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: mount devtmpfs on ~/test cause device item in side pane?

Postby seppalta » Sun Mar 04, 2018 4:14 am

Perhaps you could post an image so that we would know better what you are asking. The directories (places) listed on the pcmanfm left panel can be controlled by checking the boxes offered up in (starting in pcmanfm header bar): Edit > Preferences > Layout.

lbuiyzxl
Posts: 7
Joined: Wed Aug 09, 2017 1:29 pm

Re: mount devtmpfs on ~/test cause device item in side pane?

Postby lbuiyzxl » Sat Apr 07, 2018 10:53 am

seppalta wrote:Perhaps you could post an image so that we would know better what you are asking. The directories (places) listed on the pcmanfm left panel can be controlled by checking the boxes offered up in (starting in pcmanfm header bar): Edit > Preferences > Layout.

I'm want to avoid the devtmpfs device present in the side pane.
Image
Attachments
Screenshot from 2018-04-07 18-57-25.png
(124.3 KiB) Not downloaded yet

seppalta
Posts: 441
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: mount devtmpfs on ~/test cause device item in side pane?

Postby seppalta » Sun Apr 08, 2018 11:21 pm

I think if you just right click on the undesirable entry and click "Eject Removable Media" will get rid of it for at least that session.

General mounting controls for Pcmanfm can be reached by clicking: Edit>Preferences>Volume Management. Here you can choose to show "all" or "none". If you want some, but not "all", then you have to choose not to mount here and use "bookmarks" for the ones you want.

Or you can go to: Edit>Preferences>Layout and check "Devices" to create a Devices directory for all external media. There you can remove an item by right clicking on it and choosing "delete".

lbuiyzxl
Posts: 7
Joined: Wed Aug 09, 2017 1:29 pm

Re: mount devtmpfs on ~/test cause device item in side pane?

Postby lbuiyzxl » Tue Apr 10, 2018 3:09 am

seppalta wrote:I think if you just right click on the undesirable entry and click "Eject Removable Media" will get rid of it for at least that session.

General mounting controls for Pcmanfm can be reached by clicking: Edit>Preferences>Volume Management. Here you can choose to show "all" or "none". If you want some, but not "all", then you have to choose not to mount here and use "bookmarks" for the ones you want.

Or you can go to: Edit>Preferences>Layout and check "Devices" to create a Devices directory for all external media. There you can remove an item by right clicking on it and choosing "delete".

Thank you for pay attention to this post,but seem all your workaround is not suitable for this question.
This problem cause by I'm use a chroot in ~/* directory,I need that devtmpfs mount point,so I want umount it.
If I'm use chroot in other dictionary than ~/*,then this problem is go away.
For example:

Code: Select all

mount -t devtmpfs testdev /test


Information for version :

Code: Select all

PCManFM 1.2.5
Lightweight file manager
using LibFM ver. 1.2.5

Developed by Hon Jen Yee (PCMan)

drooly
Posts: 453
Joined: Mon Apr 08, 2013 6:45 am

Re: mount devtmpfs on ~/test cause device item in side pane?

Postby drooly » Sun Apr 15, 2018 7:10 am

Try this:

Code: Select all

mount -t devtmpfs -o comment=x-gvfs-hide testdev /test

lbuiyzxl
Posts: 7
Joined: Wed Aug 09, 2017 1:29 pm

Re: mount devtmpfs on ~/test cause device item in side pane?

Postby lbuiyzxl » Sun Jun 10, 2018 1:39 pm

drooly wrote:Try this:

Code: Select all

mount -t devtmpfs -o comment=x-gvfs-hide testdev /test

Code: Select all

sudo mount -t devtmpfs -o comment=x-gvfs-hide testdev ~/test

This command have same problem.
Note this problem is appear on "~/test" not the "/test" in your example.


Return to “PCManFM”

Who is online

Users browsing this forum: No registered users and 1 guest