Default font interpolation has changed

The standard session manager used by LXDE - http://wiki.lxde.org/en/LXSession
Sworddragon
Posts: 5
Joined: Wed Oct 13, 2010 9:42 pm

Default font interpolation has changed

Postby Sworddragon » Fri Feb 21, 2014 9:41 pm

On Ubuntu 14.04 dev after upgrading from lxsession 0.4.9.2 to 0.4.9.2+git20140216 I'm noticing a difference how fonts are interpolated. Basically more fonts are now interpolated at default but disabling AntiAliasing will result that less fonts will be interplated meaning that 0.4.9.2 has interpolated some fonts and some not if AntiAliasing was enabled.

On 0.4.9.2 in /etc/xdg/lxsession/LXDE/desktop.conf there was the entry iXft/Antialias=1. After upgrading to 0.4.9.2+git20140216 this file was created on ~/.config/lxsession/LXDE/desktop.conf with iXft/Antialias=1 and among other things with 2 new hinting entries: iXft/Hinting=1 and sXft/HintStyle=hintslight. But from the visual quality it looks like hinting was also implicitly enabled on 0.4.9.2.


Here are some screenshots:

0.4.9.2+git20140216 with iXft/Antialias=0, iXft/Hinting=1 and sXft/HintStyle=hintslight:
http://picload.org/image/ldlloao/reference.png

This is a reference to show how it looks without AntiAliasing.


0.4.9.2 with iXft/Antialias=1 and the implicit default hinting settings:
http://picload.org/image/ldlload/lxsession_old.png

As you can see the bold fonts in Firefox are not interpolated but the bold fonts in Minecraft are.


0.4.9.2+git20140216 with iXft/Antialias=1, iXft/Hinting=1 and sXft/HintStyle=hintslight:
http://picload.org/image/ldlloag/lxsession_new.png

Now the bold fonts in both applications are interpolated.


This leaves a few questions:

  • Why is there a difference on the default configuration on both versions? Has some configuration changed or was the bahavior of 0.4.9.2 a bug?
  • If it was not a bug how can I get with 0.4.9.2+git20140216 the behavior of 0.4.9.2?

Sworddragon
Posts: 5
Joined: Wed Oct 13, 2010 9:42 pm

Re: Default font interpolation has changed

Postby Sworddragon » Mon Feb 24, 2014 5:02 am

I have figured out that this happened because of subpixel rendering. Setting sXft/RGBA=rgb to sXft/RGBA=none disables this behavior and the fonts are looking again like in 0.4.9.2.


Return to “LXSession (Lite)”

Who is online

Users browsing this forum: No registered users and 1 guest