LXDM by default in US Keyboard, how change it ?

All questions and problems regarding LXDE components including LXSession, LXAppearance, GPicView, Leafpad, LXTerminal, Xarchiver, LXNM to be discussed here.

For PCManFM questions, please ask in the dedicated forum below.
Lylyrian
Posts: 3
Joined: Sat Aug 18, 2018 7:48 am

LXDM by default in US Keyboard, how change it ?

Postby Lylyrian » Sat Aug 18, 2018 7:59 am

I find this topic : viewtopic.php?f=8&t=36434&p=48772 but it doesn't answer the question.

When I start my computer, I have LXDM, the connection manager. In LXDM (and only on it), I have choice between keyboard but it is always by default on US keyboard. So boring to select my keyboard at all connection... After connection, when I am on my session, it is ok, my locale are in azerty. It's only on LXDM where the default US keyboard is annoying, because my password is not qwerty compatible. So, how I can change default preselected keyboard in LXDM (and only on this composant) ? If I disable the language selection menu, it is on US keyboard to, and I only can connect with TTY :?

drooly
Posts: 502
Joined: Mon Apr 08, 2013 6:45 am

Re: LXDM by default in US Keyboard, how change it ?

Postby drooly » Mon Aug 20, 2018 8:22 pm

after you login, there should be a way to change language/locale/keyboard settings "system wide" or "for all users".

Lylyrian
Posts: 3
Joined: Sat Aug 18, 2018 7:48 am

Re: LXDM by default in US Keyboard, how change it ?

Postby Lylyrian » Tue Aug 21, 2018 7:27 pm

After my login, system is in french for all my user, with a french keyboard. My /etc/locale.conf is

Code: Select all

LANG=fr_FR.UTF-8
#Si pas de français
LANGUAGE="fr_FR:en_US"
# tri par défaut
LC_COLLATE=C


And for %locale :

Code: Select all

LANG=fr_FR.utf8
LC_CTYPE="fr_FR.utf8"
LC_NUMERIC="fr_FR.utf8"
LC_TIME="fr_FR.utf8"
LC_COLLATE=C
LC_MONETARY="fr_FR.utf8"
LC_MESSAGES="fr_FR.utf8"
LC_PAPER="fr_FR.utf8"
LC_NAME="fr_FR.utf8"
LC_ADDRESS="fr_FR.utf8"
LC_TELEPHONE="fr_FR.utf8"
LC_MEASUREMENT="fr_FR.utf8"
LC_IDENTIFICATION="fr_FR.utf8"
LC_ALL=


But no way, LXDM stay on US keyboard by default. Maybe there are an other thing to do ?

Rex Bouwense
Posts: 1008
Joined: Sat Aug 27, 2011 5:44 pm
Location: Sierra Vista, Arizona USA
Contact:

Re: LXDM by default in US Keyboard, how change it ?

Postby Rex Bouwense » Wed Aug 22, 2018 5:53 pm

Have you used the Keyboard Layout Handler settings to change your keyboard to French? Theoretically, you can change from one to the other or you can eliminate the US keyboard entirely.
Rex
Lubuntu 18.04

drooly
Posts: 502
Joined: Mon Apr 08, 2013 6:45 am

Re: LXDM by default in US Keyboard, how change it ?

Postby drooly » Sun Aug 26, 2018 10:41 am

Lylyrian wrote:But no way, LXDM stay on US keyboard by default. Maybe there are an other thing to do ?

hmm.
maybe lxdm requires its own locale configuration?
have you tried editing the appropriate config files?

http://manpages.ubuntu.com/manpages/cos ... xdm.1.html

Lylyrian
Posts: 3
Joined: Sat Aug 18, 2018 7:48 am

Re: LXDM by default in US Keyboard, how change it ?

Postby Lylyrian » Sun Feb 24, 2019 9:07 pm

I tried all and noting work, I just forgot to say I resolve it (sort of) by installing another connection manager (LightDM). It work better :)

zorba395
Posts: 3
Joined: Sun Feb 24, 2019 1:34 pm

Re: LXDM by default in US Keyboard, how change it ?

Postby zorba395 » Mon Feb 25, 2019 9:22 am

Ok Lylyrian, thanks for the update.

I havn't give-up yet... :)

If I find a solution I'll post it here.

Bye,

zorba395
Posts: 3
Joined: Sun Feb 24, 2019 1:34 pm

Re: LXDM by default in US Keyboard, how change it ?

Postby zorba395 » Wed Mar 20, 2019 8:55 am

@ Lylyrian,

I also tried everything and nothing worked.

I also posted a new tread on this forum and didn't receive a single answer!

So I finally took the same decision as you: forget about LXDM and install LightDM only to use the greeter, once I'm login, I use Enlightenment DE and very happy with it.

However, I'm facing the same issue: cannot get the "be" keyboard layout for the greeter login screen!
Using setxkbmap in lightdm.conf doesn't work! :oops:

Thanks for your help,
M.T.

drooly
Posts: 502
Joined: Mon Apr 08, 2013 6:45 am

Re: LXDM by default in US Keyboard, how change it ?

Postby drooly » Mon Apr 01, 2019 7:03 am

zorba395 wrote:Using setxkbmap in lightdm.conf doesn't work! :oops:

Lightdm is not the same as LXDM!
in case you need a solution for lightdm: https://wiki.archlinux.org/index.php/Li ... _displayed

general configuration for LXDM: https://wiki.archlinux.org/index.php/LXDM#Configuration

Alexander256
Posts: 1
Joined: Thu Nov 29, 2018 10:22 am

Re: LXDM by default in US Keyboard, how change it ?

Postby Alexander256 » Tue Apr 16, 2019 11:19 am

think that I've made a concept to re-design the LXmenu... If someone could ever create something like this, I would personally be very grateful


Return to “LXDE Components”

Who is online

Users browsing this forum: No registered users and 1 guest