lxdm doesn't authenticate nis users correctly

All questions and problems regarding LXDE components including LXSession, LXAppearance, GPicView, Leafpad, LXTerminal, Xarchiver, LXNM to be discussed here.

For PCManFM questions, please ask in the dedicated forum below.
mathiraj
Posts: 12
Joined: Wed Apr 21, 2010 5:37 pm

lxdm doesn't authenticate nis users correctly

Postby mathiraj » Wed Apr 21, 2010 5:42 pm

i'm using lubuntu 10.4 beta 2 with lxdm

My system is a nis client. i'm able to login the system from command line. But lxdm doesn't let me login. Everytime I enter username/password, the screen blinks for a second and again the login screen is displayed.

I tried other dm's like xdm, wdm & gdm and they all let me login.

Is this a known issue with lxdm?

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: lxdm doesn't authenticate nis users correctly

Postby Marty Jack » Thu Apr 22, 2010 9:56 am

This is not my area but looking at the code I see no indication that LXDM supports NIS. Again, it is not my decision, but I would suspect that this is not a feature we would add. One of the ways LXDE remains lightweight is to carve out areas that it does not go into. Unlike the all inclusive environments such as GNOME and KDE, it is designed so that you can use any display manager and any window manager. If you need NIS authentication, you should plan to use one of the display managers that supports it with our blessings.

mathiraj
Posts: 12
Joined: Wed Apr 21, 2010 5:37 pm

Re: lxdm doesn't authenticate nis users correctly

Postby mathiraj » Thu Apr 22, 2010 5:15 pm

First of all thank you for your reply.

But I can't believe that something needs to be added to lxdm that would make it heavy weight like gdm and kdm to make it support nis authentication.

In fact I'm using xdm & wdm which are as light wight as lxdm (if not more) and they let me login with the nis user account.

If lxdm supports this, great. If not, that is also great :)

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: lxdm doesn't authenticate nis users correctly

Postby Marty Jack » Thu Apr 22, 2010 11:19 pm

In this case the tradeoff is not whether it takes 100 lines or 10,000 lines of code to have. The tradeoff has to do with making the best use of engineering resources and with the difficulty of long term maintenance. While NIS authentication is a valid thing to want, the vast majority of LXDE users are not in a network environment where it would be available to be used. The same with other longer distance authentication mechanisms like LDAP, Kerberos, whatever. If we were to have support for this, it would be necessary to set up an adequate test environment when it was implemented and keep that available so it could be retested with every new release. For now, getting the product to work smoothly in the SELinux and PAM and PolicyKit environment in such distros as OpenSUSE and Fedora is proving an adequate challenge.

This situation could of course change over time and I am confident the product would evolve as needed.

DavidLee
Posts: 3
Joined: Wed Jul 14, 2010 7:56 pm

Re: lxdm doesn't authenticate nis users correctly

Postby DavidLee » Wed Jul 14, 2010 8:05 pm

I have been trying, unsuccessfully, to authenticate using winbind and a Samba PDC. Can I assume this does not at present work for the same reason?

I thought that all authentication was passed over to the PAM modules, and given that I can log on with a domain account on a standard terminal, I would have expected the same to apply within LXDE. However, having enabled debug on the PAM modules, there is no sign of the domain user name ever reaching PAM.

Does this have a simple explanation, or even a simple solution?

cwickert
Posts: 47
Joined: Tue Dec 09, 2008 7:36 pm
Location: Münster, Germany
Contact:

Re: lxdm doesn't authenticate nis users correctly

Postby cwickert » Wed Jul 14, 2010 10:09 pm

Can you please file feature requests in the tracker to make sure this reaches the author of the software and can be tracked properly?

TIA,
Christoph
Image

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: lxdm doesn't authenticate nis users correctly

Postby Marty Jack » Fri Jul 16, 2010 12:09 am

Once again, this is not my area of concentration and I did not develop LXDM, but having looked a little further at this, it should indeed be the case that the authentication for all logins is mediated by PAM, and that if the NIS-or-whatever-through-PAM path is working properly for the other display managers, it should be working for LXDM. At the moment I am equally puzzled, but I will continue to investigate.

cwickert
Posts: 47
Joined: Tue Dec 09, 2008 7:36 pm
Location: Münster, Germany
Contact:

Re: lxdm doesn't authenticate nis users correctly

Postby cwickert » Fri Jul 16, 2010 6:58 am

Marty Jack wrote:Once again, this is not my area of concentration [...]

Marty, please note that I was not asking you to file the feature request but mathiraj and David. If they think LXDM should support this or that feature, the should file a feature request in the tracker instead of writing about it in the forum.

@mathiraj and David: What version of LXDM are you using? Latest GIT? There have been a couple of changes to make sure that LXDM works with SELinux and it should only use PAM now. The question is if this works or not.

Regards,
Christoph
Image

DavidLee
Posts: 3
Joined: Wed Jul 14, 2010 7:56 pm

Re: lxdm doesn't authenticate nis users correctly

Postby DavidLee » Mon Jul 19, 2010 9:05 pm

Thank you Marty Jack and Christoph for your responses. I will try entering details in the tracker - never needed to do that before, but that shouldn't be a show stopper

Christoph asked
What version of LXDM are you using? Latest GIT?

dpkg.log says I have
lxde-common 0.5.0-3ubuntu2
lxde-core 0.5.0-3ubuntu2
lxdm 0.2.0~svn2307+git20100408-0ubuntu1

DavidLee
Posts: 3
Joined: Wed Jul 14, 2010 7:56 pm

Re: lxdm doesn't authenticate nis users correctly

Postby DavidLee » Mon Jul 19, 2010 9:30 pm

Thank you Marty Jack and Christoph for your responses. Entered in the tracker - https://sourceforge.net/tracker/?func=d ... tid=894872 - which I hope is correct, as it is the first time I have used the tracker.

Christoph asked
What version of LXDM are you using? Latest GIT?

dpkg.log says I have
lxde-common 0.5.0-3ubuntu2
lxde-core 0.5.0-3ubuntu2
lxdm 0.2.0~svn2307+git20100408-0ubuntu1


Return to “LXDE Components”

Who is online

Users browsing this forum: No registered users and 2 guests