[BUG?] Network management symbol irritated.

Discussion on LXDE releases and Development. This forum is not the best way to contact the developers, please use the Development mailing list and Sourceforge to interact with them.
Grimeton
Posts: 2
Joined: Wed Aug 14, 2019 12:08 pm

[BUG?] Network management symbol irritated.

Postby Grimeton » Wed Aug 14, 2019 12:23 pm

Hi,

Ok, I know there's a mailing list, but I don't want to subscribe to it. Too big a mess in the e-mail client. I hope someone can forward this, so that it can get fixed.

Situation is as follows:

- Raspberry Pi 3B+ with Raspbian and LXDE.
- Built-in WiFi and WiFi dongle connected to the Pi as wlan0 and wlan1.
- wlan0 is used as access point, so it's ignored by systemd and systemd does not start wpa_supplicant there.

This can be achieved by various ways, the most common way seems to be to unhook the wpa_supplicant script in udhcpcd.conf or by just telling udhcpcd in its configuration file to ignore the device completely. Something like "denyinterfaces wlan0" works.

Another option is to use something like
interface wlan0
nohook wpa_supplicant

The result is the same, the interface is ignored and hostapd can take over.

The problem now starts when you login to the desktop. When you hold the mouse over the network icon, it shows all the network connections correctly, but a click on the icon always tells you that the country setting has not been set. Whatever you do from there on, you cannot change the country setting and the problem never goes away which basically renders the whole network menu unusable.

You are not able to access any network settings at all because all you get is that the country setting is not set. So as far as I understand this, the wlan0 interface should actually be ignored by the network applet or it is missing some information. Hostapd sets the country setting, but that doesn't seem to get through to the applet because systemd is not taking care of the interface. The question now is: should the applet even recognize the interface at all, or does it get the information about wlan0 from somewhere else which in the end confuses it?

I also tested and switched this around and made wlan1 the AP while wlan0 was the client connection. Result is the same. The interface that is not managed via systemd/udhcpcd and wpa_supplicant always pops up as "country setting not set", locking the whole menu from being used any further.

The underlying system itself works as expected. It's just a display error in the applet.

If you have questions, feel free to ask and I will try to help.

KR,

G.

drooly
Posts: 576
Joined: Mon Apr 08, 2013 6:45 am

Re: [BUG?] Network management symbol irritated.

Postby drooly » Sat Aug 17, 2019 7:49 am

Are you sure you're using "just " the lxpanel applet or actually network-manager's nm-applet?
Or maybe Wicd?

Grimeton
Posts: 2
Joined: Wed Aug 14, 2019 12:08 pm

Re: [BUG?] Network management symbol irritated.

Postby Grimeton » Sat Aug 17, 2019 12:39 pm

There's neither wicd nor NM in play. I can install wicd or NM if I want to, but it's not installed by default.


Return to “LXDE Development & Programming”

Who is online

Users browsing this forum: No registered users and 2 guests