Gnome Volume Control

Please post all general support questions for LXDE here.
Locked
Visserys
Posts: 1
Joined: Tue Sep 29, 2009 11:23 pm

Gnome Volume Control

Post by Visserys »

Hi,

I was just wondering if someone knew a way to use the gnome volume control applet as the default applet in lxde.
I can type into terminal "gnome-volume-control" and bring up the window and control the volume that way, but I want the actual applet that is used in gnome to be in the task bar.
The reason I want this, is because the default volume control doesn't easily let me control my microphone levels and Im trying to setup lxde for gaming. It's just a bit of a pain to have to manually pull up the gnome volume control via terminal or alt-f2 everytime i log in.

Any games I play, run much faster under LXDE :D by the way

Thanks!

archibald haddock
Posts: 148
Joined: Sun Jan 11, 2009 6:57 pm

Re: Gnome Volume Control

Post by archibald haddock »

I have not heard that gnome-panel plugins are compatible to lxde panel. Lxde panel does not ship gnome deps.
You could write your own plugin are bind some keys to the micro volume. xbindkeys is quite good at it.

comgen
Posts: 2
Joined: Wed Oct 07, 2009 4:12 pm
Location: North Carolina USA

Re: Gnome Volume Control

Post by comgen »

1. Copy from: /usr/share/applications/

gnome-volume-control.desktop

2. To: /home/USERnameHERE/.config/autostart/

You may need to edit the file and toggle true / false on / off and/or use the " Desktop Session Settings " app.

However, I have found the provide lxde panel volume control does a much better job

or

1. create a new autostart config file: ~/.config/autostart/gvolume.desktop ( whatever you want to call it )

( ubuntu 9.10 current build )
2. Add the following:

[Desktop Entry]
Name=Volume Control
Comment=Show desktop volume control
Icon=multimedia-volume-control
Exec=gnome-volume-control-applet
Terminal=false
Type=Application
Categories=
NoDisplay=true
OnlyShowIn=GNOME;XFCE;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-media
X-GNOME-Bugzilla-Component=gnome-volume-control
X-GNOME-Autostart-Notify=true
X-Ubuntu-Gettext-Domain=gnome-media-2.0

3. restart session

Also,

# ObConf should be installed to the /usr prefix to have file associations function correctly.
# When ObConf is installed, upgraded or uninstalled, you need to run these commands to update the .obt
# file associations for GNOME:

sudo update-mime-database /usr/share/mime
sudo update-desktop-database /usr/share/applications
..
Best regards,
comgen

Locked