Suspend to Ram and screen lock

Please post all general support questions for LXDE here.
prh
Posts: 1
Joined: Tue Nov 09, 2010 9:35 am

Suspend to Ram and screen lock

Postby prh » Tue Nov 09, 2010 9:49 am

Hi all.

I've set up dedicated box for mythtv using OpenSUSE 11.3 with LXDE as the desktop.

Before executing a suspend-to-ram, the screen lock is activated.

This box will run without a keyboard, and I want to disable the screen locking, bit I can't find a setting to do this.

Is there a config file somewhere I can tweak to turn off the screen locking?

Thanks for any advice.

Regards, Paul

lyovushka
Posts: 8
Joined: Sun Nov 07, 2010 4:11 pm

Re: Suspend to Ram and screen lock

Postby lyovushka » Thu Nov 11, 2010 1:54 am

I think you can disable this from xscreensaver preferences (in Lubuntu Preferences -> Screensaver). There is a checkbox in bottom left corner.

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: Suspend to Ram and screen lock

Postby Marty Jack » Thu Nov 11, 2010 4:48 am

Right. Assuming you have gnome-screensaver and gnome-screensaver-preferences, you can run the preferences setter from a terminal if all else fails and you can't find a menu item for it. It could also be that you have xscreensaver.

Nothing stops you from just deinstalling the screensaver if you don't want to use it. This is all there to avoid a fairly large security hole when you do have a screen.

nobange
Posts: 16
Joined: Thu Aug 19, 2010 10:00 pm
Location: Gorzów Wlkp., Poland

Re: Suspend to Ram and screen lock

Postby nobange » Mon Nov 29, 2010 8:50 pm

I have the same problem, don't want to lock my screen afer resume from sleep, but default installed XFCE Power Manager doesn't respect my setting and still scrren is locking. I don't want to deinstall xscreensaver, I use it but without password. There must be a config file where this thing can be disabled.

stqn
Posts: 1
Joined: Wed Jan 18, 2012 10:04 pm
Contact:

Re: Suspend to Ram and screen lock

Postby stqn » Wed Jan 18, 2012 10:13 pm

I have the same problem, can't find any way to prevent lxde-logout/lxde-session from locking the screen before suspend to ram (sleep) / suspend to disk (hibernate).

So after several hours of research I tried to kill XScreenSaver before suspend to ram, and it worked! (I'm using Debian Squeeze BTW.)

Just:
sudo leafpad /etc/pm/sleep.d/00_kill_xscreensaver.sh

with the following line:
pkill xscreensaver

Don't forget to:
sudo chmod 700 /etc/pm/sleep.d/00_kill_xscreensaver.sh

That's it. Not pretty but it works :).

Edit: I don't know if it's because I killed xscreensaver, but now lxde-logout doesn't want to hibernate or suspend anymore. I have to use "sudo bash -c 'echo disk > /sys/power/state'" to hibernate.


Return to “General Help”

Who is online

Users browsing this forum: Bing [Bot] and 5 guests