how to bind "Super key" to "LXDE menu"

Please post all general support questions for LXDE here.
longtth
Posts: 3
Joined: Fri Mar 02, 2012 3:39 pm

how to bind "Super key" to "LXDE menu"

Postby longtth » Thu Mar 08, 2012 1:53 pm

Dear all,
I want to bind the "Super key" to open LXDE Menu (img below) but cant find the action in Openbox help
Anyone know what action is it? Please give an advice! Many thanks!
Image

M_Mynaardt
Posts: 72
Joined: Wed Dec 15, 2010 9:37 pm
Location: Victoria, BC, Canada

Re: how to bind "Super key" to "LXDE menu"

Postby M_Mynaardt » Thu May 17, 2012 2:57 pm

huihs wrote:3. On a serious note, why is Blizzard making everyone wait Diablo 3 Gold for Sale until Cali hits 12am for the game to go live? 3am?! Come on. I was excited about the release of this game but like my star craft 2 it wont get played because the game requires you to have a constant internet connection. This is a bad direction for game developers to take th


Some bozos have put spam, including that one, in pretty well every topic in the last day or two.

Pretty annoying, really...
:evil:
~*~ M_Mynaardt ~*~

LXDE is your computer's Friend!
Always trust LXDE!

Rex Bouwense
Posts: 950
Joined: Sat Aug 27, 2011 5:44 pm
Location: Sierra Vista, Arizona USA

Re: how to bind "Super key" to "LXDE menu"

Postby Rex Bouwense » Fri May 18, 2012 12:38 am

It seems a shame since there are so few of us that are active in this forum that some knuckle-head(s) have to SPAM the forums for no reason other than they can. Where are the moderators when you need them?
Getting back to the subject, the super key is already binded (is that a word) to the start menu in Lubuntu 11.10. What distro are you using?
Rex
Lubuntu 16.04

M_Mynaardt
Posts: 72
Joined: Wed Dec 15, 2010 9:37 pm
Location: Victoria, BC, Canada

Re: how to bind "Super key" to "LXDE menu"

Postby M_Mynaardt » Fri May 18, 2012 1:49 am

Rex Bouwense wrote:It seems a shame since there are so few of us that are active in this forum that some knuckle-head(s) have to SPAM the forums for no reason other than they can. Where are the moderators when you need them?
Getting back to the subject, the super key is already binded (is that a word) to the start menu in Lubuntu 11.10. What distro are you using?


I sometimes think posting spam should be a capital offence.
If it inconveniences me, of course!
:twisted:

But, seriously... I am using Lubuntu 12.04 on my ageing laptop (a Toshiba Satellite A100). I seem to have the opposite problem you do; the super key always brings up the LXDE main menu on the panel. I don't want it to, though. I'd like to use the super key for hot key combinations. For instance, I'd like to have super-w to open my web browser, or super-e to open my text editor, etcetera. I've tried making keybindings with hot-key combinations using the super key but the only thing that happens is the LXDE menu on the panel opens up.

I've managed to make hot-key combinations using ctrl-alt instead of super. I just wish I knew how to turn off the keybinding for the super key. If there is a way to turn it on or off, I'm not knowledgeable enough to figure that out from the oepnbox xml file.

Anyone out there reading this able to tell us how to turn on/off the super key in the openbox keybindings?
:?:

Thanks!
~*~ M_Mynaardt ~*~

LXDE is your computer's Friend!
Always trust LXDE!

gymka
Posts: 27
Joined: Fri May 18, 2012 6:15 am
Location: Kaunas
Contact:

Re: how to bind "Super key" to "LXDE menu"

Postby gymka » Fri May 18, 2012 6:31 am

BIND:
in ~/.config/openbox/lxde-rc.xml, keyboard section add:

Code: Select all

<keybind key="Super_L">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>

UNBIND:
in ~/.config/openbox/lxde-rc.xml, keyboard section remove:

Code: Select all

[code]<keybind key="Super_L">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>[/code]

it's explained in lxde wiki...
"Kvailam gimti ne sarmata. Tik mirti kvailam gėda." E. M. Remarkas
"Родиться глупым не стыдно, стыдно только умирать глупцом." Э. М. Ремарк
"To born stupid is not shame, just to die stupid is shameful." E. M. Remarque

huihs
Posts: 8
Joined: Tue May 15, 2012 1:23 am

Re: how to bind "Super key" to "LXDE menu"

Postby huihs » Fri May 18, 2012 8:16 am

dawdsdfqdqdqwdqwdqweq

M_Mynaardt
Posts: 72
Joined: Wed Dec 15, 2010 9:37 pm
Location: Victoria, BC, Canada

Re: how to bind "Super key" to "LXDE menu"

Postby M_Mynaardt » Fri May 18, 2012 2:08 pm

gymka wrote:BIND:
in ~/.config/openbox/lxde-rc.xml, keyboard section add:

Code: Select all

<keybind key="Super_L">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>

UNBIND:
in ~/.config/openbox/lxde-rc.xml, keyboard section remove:

Code: Select all

[code]<keybind key="Super_L">
      <action name="Execute">
        <command>lxpanelctl menu</command>
      </action>
    </keybind>[/code]

it's explained in lxde wiki...


Right on!

Thanks for that!
~*~ M_Mynaardt ~*~

LXDE is your computer's Friend!
Always trust LXDE!

M_Mynaardt
Posts: 72
Joined: Wed Dec 15, 2010 9:37 pm
Location: Victoria, BC, Canada

Re: how to bind "Super key" to "LXDE menu"

Postby M_Mynaardt » Sat May 19, 2012 5:08 pm

Right!! Got it all sorted out now, thanks to the posts here from gymka!
:D

I found this section in the defaults in ~/.config/openbox/lubuntu-rc.xml for turning on the Super Key (usually has the Windoze logo on it). I commented this out, so pressing the super key would not open the LXDE menu and allow me to use the super key for hot-key combinations:

Code: Select all

<keybind key="Super_L">
  <action name="Execute">
    <command>lxpanelctl menu</command>
  </action>
</keybind>

<keybind key="Super_R">
  <action name="Execute">
    <command>lxpanelctl menu</command>
  </action>
 </keybind>


I then added these things to make the hot-key combinations I wanted to have:

Code: Select all

<!-- My own personal keybindings -->
   
<!-- Super-L to lock the screen with the screen saver -->
<keybind key="W-l">
  <action name="Execute">
    <command>xscreensaver-command -lock</command>
  </action>
</keybind>
   
<!-- Super-x to execute the logout command -->
<keybind key="W-x">
  <action name="Execute">
    <command>
      lxsession-logout --banner=/home/user/.extra-icons/1204-logout-banner.png --side=top
    </command>
  </action>
</keybind>

<!-- Super-w to execute my prefered browser; Opera -->
<keybind key="W-w">
  <action name="Execute">
    <command>opera</command>
  </action>
</keybind>
   
<!-- Super-m to execute my prefered email client; Sylpheed -->
<keybind key="W-m">
  <action name="Execute">
    <command>sylpheed</command>
  </action>
</keybind>

<!-- Super-e to execute my prefered text editor; gedit -->
<keybind key="W-e">
  <action name="Execute">
    <command>gedit</command>
  </action>
</keybind>


These all work fine, using the super key as part of a hot-key combination. And all is right with the world. Or at least my laptop using Lubuntu, anyway! I'm just including all these keybinding statements I've used (successfully) in case anyone reading this wants some idea how to do their own key-bindings with the Openbox configuration stuff...

Thanks again, for the information gymka!
8-)
~*~ M_Mynaardt ~*~

LXDE is your computer's Friend!
Always trust LXDE!

gymka
Posts: 27
Joined: Fri May 18, 2012 6:15 am
Location: Kaunas
Contact:

Re: how to bind "Super key" to "LXDE menu"

Postby gymka » Sun May 20, 2012 5:12 am

"Kvailam gimti ne sarmata. Tik mirti kvailam gėda." E. M. Remarkas
"Родиться глупым не стыдно, стыдно только умирать глупцом." Э. М. Ремарк
"To born stupid is not shame, just to die stupid is shameful." E. M. Remarque


Return to “General Help”

Who is online

Users browsing this forum: No registered users and 5 guests