Disabling Save for session aand Save for Keyring LXDE way

Please post all general support questions for LXDE here.
venkat_330
Posts: 1
Joined: Mon Nov 30, 2015 11:26 am

Disabling Save for session aand Save for Keyring LXDE way

Postby venkat_330 » Thu Jul 06, 2017 7:23 am

I am using minimal Debian(Jessie) with lxde-common installed for UI application view. With this configuration I am trying to run "GKSU" with ti configured shortcut key.
it works as expected. However, the user password entry box for GKSU contains 2 option under remember password, which i want to disable completely across system
[img]
https://i.stack.imgur.com/1wm1s.png[/img]
Option 1: Save for session
Option 2: save for Keyring

For my application use case I do not want these option. Need some guidance for these setting changes

Mentioned are some of trials i have done from end

Command used for executios:

Code: Select all

   gksu -u test /usr/bin/xterm

Trail 1 : gconftool (Result : failed)

Code: Select all

gconftool-2 --direct --config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory --type bool --set /apps/gksu/save-to-keyring false


Trail 2: Disabling daemon execution permission (Result : failed)

Code: Select all

   chmod +x $(type -p gnome-keyring)

Trial 3: Commenting of pam_gnome_keyring under lightdm pam.d

In /etc/pam.d/lightdm two lines are commented (Result : "save for Keyring" was disabled)

Code: Select all

    #auth  optional pam_gnome_keyring.so
    #session optional        pam_gnome_keyring.so auto_start


I am still not able to find a solution on disabling "Save for session" feature. Request some guidance

Return to “General Help”

Who is online

Users browsing this forum: No registered users and 6 guests