Which version of LXDE do I have?

Please post all general support questions for LXDE here.
LinuxUserNZ
Posts: 6
Joined: Mon Jan 01, 2018 3:32 am

Which version of LXDE do I have?

Postby LinuxUserNZ » Mon Jan 01, 2018 3:58 am

I've been using Linux since about 2008, and have been using Lubuntu for most of that time. Before the next LTS version comes out in April 2018, I am trying to standardise my systems somewhat, and in doing so I am building my own, private knowledgebase using Tiddlywiki. During this process, I am documenting all of my computer systems, and the software currently installed on them, plus any changes I may have made along the way, so that I can streamline the rollout of 18.04 when it arrives.

To that end, I would like to document my existing LXDE installation. I see on the LXDE Wiki, that it lists the current version of LXDE as being 0.99.2 (last updated 25 January 2017‎), but I have no idea how to compare this to my existing installations/instances. I see that each individual component of LXDE also has its own version number, so I can no doubt compare them individually. But how is that 0.99.2 version calculated, collectively? Thanks.

LinuxUserNZ
Posts: 6
Joined: Mon Jan 01, 2018 3:32 am

Re: Which version of LXDE do I have?

Postby LinuxUserNZ » Fri Feb 02, 2018 5:32 pm

Just a gentle bump here. Can anyone answer this question for me please? I'm hoping to get things put in place before the next major release of Lubuntu, and it would be very helpful for my own documentation efforts to know what version of LXDE I'm running, and how to tell the difference. Thanks.

seppalta
Posts: 440
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Which version of LXDE do I have?

Postby seppalta » Sat Feb 03, 2018 6:18 pm

I have read that Lubuntu is changing to LXQT, which is a different beast, and, therefore, your comparison work will be for naught. In any case, LXDE is very simple and made up of just a few independent packages. Update them and you have latest lxde desktop. See http://lxlinux.com/indexold.html, which is an old version of http://lxlinux.com.

LinuxUserNZ
Posts: 6
Joined: Mon Jan 01, 2018 3:32 am

Re: Which version of LXDE do I have?

Postby LinuxUserNZ » Sat Feb 03, 2018 8:47 pm

Thanks for that seppalta. Indeed, I am aware of the impending change to LXQt, but I'm not sure if it is due out in Lubuntu 18.04 LTS or not. I would have assumed that, being such a radical change, it wouldn't be released with an LTS version, which is normally reserved for well tested and very stable changes only. Your links were very helpful, thanks for those. It still doesn't answer my original question though, does it? How is that v0.99.2 version number calculated? How do I know that I am running LXDE v0.99.2? Or do I just have to check the version numbers of each individual component of LXDE, and then assume?

seppalta
Posts: 440
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Which version of LXDE do I have?

Postby seppalta » Sun Feb 04, 2018 2:55 am

Do you have synaptic installed? It will tell you your "installed version" and the "latest version." Just check "lxde" or "lxde core".

LinuxUserNZ
Posts: 6
Joined: Mon Jan 01, 2018 3:32 am

Re: Which version of LXDE do I have?

Postby LinuxUserNZ » Sun Feb 04, 2018 4:02 am

Ah, thanks for that. Both lxde and lxde-core show as v9 for me, but there is also an lxde-common (LXDE common configuration files) which shows as v0.99.2-3 in Synaptic, which makes sense. That was the answer I was looking for. Thanks for your help! :)

EDIT: Darn, I just noticed that I was reading the wrong column, my "installed version" column for all three lxde packages is empty. The "latest version" column is the one I was looking at above. I see there is no tick beside these packages at all, to indicate that they are installed. I'm definitely using Lubuntu, and I have not installed any other desktop environment, so I should have LXDE installed, but it isn't showing as such in Synaptic. Weird!

EDIT: I just checked a VM that I'm using with the above-mentioned project. The VM is running Lubuntu v17.10.1 with LXDE as its only DE, and in Synaptic it is showing exactly the same results as above, no installed packages for lxde, lxde-core, or lxde-common. It shows the latest available packages, but nothing as being currently installed. I'm confused!

EDIT: To confirm, on the host machine (running Lubuntu v17.04), I have got OpenBox v3.6.1, PCManFM v1.2.5, LXPanel v0.9.3, and LXSession v0.5.3 all installed.

seppalta
Posts: 440
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Which version of LXDE do I have?

Postby seppalta » Sun Feb 04, 2018 6:50 am

Have you reloaded synaptic, or done sudo apt-get update in a terminal?

If you have dpkg installed, then you can run

Code: Select all

dpkg -s appname
in a terminal to get loads of information about "appname", including what the latest version is and what is installed on your machine.

Ubuntu (Lubuntu) has a tendency to put their own stamp on common Linux processes and applications, which is arrogant and one reason to not use them. So what the rest of the Linux World calls "xyz", Lubuntu might call lubuntu-xyz. This might explain why the applications are showing "not installed.," although I doubt if all of the ones you mentioned would have special lubuntu names.


Return to “General Help”

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests