Alt-Tab does not focus selected window

Please post all general support questions for LXDE here.
kolfen
Posts: 2
Joined: Mon Feb 05, 2018 2:23 am

Alt-Tab does not focus selected window

Postby kolfen » Mon Feb 05, 2018 2:43 am

I've recently installed LXDE and I'm pretty sure Alt-Tab used to work at first a few days ago, but now after some configuration changes and lots of new installations and setting things up, alt-tabbing between windows is broken in that the focus is left to the currently selected window and not the one I selected in the alt-tab dialog. The only way to give focus to another window is to click on the taskbar. I'm attaching a
output.mp4.zip
(263.31 KiB) Downloaded 18 times
showing the effect.

kolfen
Posts: 2
Joined: Mon Feb 05, 2018 2:23 am

Re: Alt-Tab does not focus selected window

Postby kolfen » Mon Feb 05, 2018 5:53 pm

Some further developments into this issue: I tried running openbox with --debug and/or --debug-focus. Unfortunately when I do so, it does not pull settings files from the usual location and also the bug wasn't reproduced. So what I did was copy the default rc from /etc/xdg/openbox/rc.xml over the ~/.config/openbox/lubuntu-rc.xml and this also fixed the alt-tab problem. I'm now gradually restoring my settings so I can isolate what entry specifically was causing the issue and I'll get back if I find it.

drooly
Posts: 440
Joined: Mon Apr 08, 2013 6:45 am

Re: Alt-Tab does not focus selected window

Postby drooly » Fri Feb 09, 2018 7:45 am

thank you for posting what is essentially the solution!


Return to “General Help”

Who is online

Users browsing this forum: No registered users and 5 guests