Shortcut Key to Show Hidden Panel?

Please post all general support questions for LXDE here.
lotharyx
Posts: 1
Joined: Wed Mar 06, 2019 12:53 pm

Shortcut Key to Show Hidden Panel?

Postby lotharyx » Wed Mar 06, 2019 1:00 pm

Hi! I like having my panel set to hide intelligently. My problem now is due to the fact that I'm running a full-screen x2go session from another machine with an auto-hiding taskbar, and I have like one-pixel-wide row of space for the mouse wherein the remote LXDE panel appears, before the host's taskbar appears and covers it up! So I was wondering if there's a way to set a shortcut key to show the panel.

vaughant
Posts: 1
Joined: Sun Feb 02, 2020 3:19 pm

Re: Shortcut Key to Show Hidden Panel?

Postby vaughant » Sun Feb 02, 2020 3:53 pm

This problem of the Panel being hidden by applications that are in full screen mode also plagues the Raspian Operating system on the Raspberry Pi. It is still a bug on the Buster version and has been at least since 2011. It is nice to be able to hide the taskbar panel so that you can get full use of the screen. You can do this by checking off "Minimize panel when not in use" under "Automatic Hiding" in the advanced tab of the LXDE Panel Preferences (right click panel/taskbar and select "Panel Settings"). However, if you do this, then an application that is maximized in full screen mode will cover it and can no longer access it. For example, maximizing the file manager to full screen does this.

There is another checkbox option in the Panel Preferences under the "Advanced" tab, called "Reserve space and not covered by maximized windows". It would seem that this option should solve this problem but it does not. It has no effect. In fact, the option "Reserve space and not covered by maximized windows" does not even work if "Minimize panel when not in use" is not checked. So the option "Reserve space and not covered by maximized windows" seems to be useless.

There was a person who pointed out this bug on this forum in 2011 in this post:

viewtopic.php?f=21&t=31407#p38067

A developer responded to his post but did not seem to understand the problem. Since the Raspberry Pi is now one of the best-selling general purpose computers of all time, edging out the Commodore 64 in the all-time rankings with over 25 million having been sold, this problem potentially effects millions of people. It does not seem like it should a hard bug to fix. The panel should simply appear when ever the mouse pointer crosses over the top (or bottom) of the screen. I wish I could fix it, but I have no idea where to start.


Return to “General Help”

Who is online

Users browsing this forum: No registered users and 3 guests