Page 1 of 1

LXDE not starting

Posted: Sun Nov 15, 2020 10:25 am
by hbdevelop1
Hello,

I had ~/.cache/lxsession/LXDE/run.log fill up 100% of my HDD.
I had to delete it to free up disk space.
But now LXDE doesn't start.
I have learned that lightdm should start both LXDE and OpenBox, but only the latter ends up running at the end of the start process.
I tried dpkg-reconfigure with lightdm, lxsession, openbox and LXDE packages.
But no success.

Any idea ?

Thank you
hbdevelop1

Re: LXDE not starting

Posted: Mon Nov 16, 2020 6:53 pm
by drooly
hbdevelop1 wrote:
Sun Nov 15, 2020 10:25 am
I had ~/.cache/lxsession/LXDE/run.log fill up 100% of my HDD.
I had to delete it to free up disk space.
That is very sad because that file would have contained some information about what's wrong with your system...
hbdevelop1 wrote:
Sun Nov 15, 2020 10:25 am
But now LXDE doesn't start.
Please elaborate.
I have learned that lightdm should start both LXDE and OpenBox, but only the latter ends up running at the end of the start process.
There should be a choice of an LXDE session and an Openbox session.
I tried dpkg-reconfigure with lightdm, lxsession, openbox and LXDE packages.
Tried? And succeeded?
Next time you try, please show us all commands entered & full output received, in CODE tags.

Re: LXDE not starting

Posted: Sat Nov 21, 2020 9:45 pm
by hbdevelop1
Hi Drooly,

Thank you for your reply.

1 -
I am linking to the following :
A- screen shot of what I see on my screen.
B- the output of ps -aux
C- some log files.

https://drive.google.com/drive/folders/ ... sp=sharing

Let me know if anyone need more info.

2-
You said that there should be a choice of an LXDE session and an Openbox session.
But in my case I've never seen any choice. LXDE just ends up running at the end of the boot.

3-
The only way to have the usual desktop is by manually running
$ /usr/bin/startlxde &

Thank you

Re: LXDE not starting

Posted: Sun Nov 22, 2020 10:16 am
by drooly
Why do you have all these root-owned files in your home folder? Something is very wrong in your screenshot.
I couldn't really look at the text files, please use a pastebin and always explain where the file comes from, in which context it was created and which command created it.

Re: LXDE not starting

Posted: Sun Nov 22, 2020 10:27 pm
by hbdevelop1
Hi Drooly,

1- The terminal screen shot is showing the content of /var/log, not my home directory.

2- Here are few log files at the end of the boot:
/var/log/Xorg.0.log -> https://appp.me/21e2K9
/var/log/syslog -> https://appp.me/jJ7I1y
/var/log/boot.log -> https://appp.me/j6qK1M
/var/log/auth.log -> https://appp.me/jPD3mr
ps -aux -> https://appp.me/JQ1RMZ

Let me know if you need more info.

Thank you

Re: LXDE not starting

Posted: Tue Nov 24, 2020 8:29 pm
by drooly
Upon superficial reading, I see no "error"s or "fail"s in these logs.
Sorry.

Re: LXDE not starting

Posted: Thu Nov 26, 2020 5:59 am
by hbdevelop1
Thank you, Drooly, for your attempt to help

Re: LXDE not starting

Posted: Sat Nov 28, 2020 3:05 pm
by GalmOne
At that point, I'd attempt reinstalling LXDE, as the files are, quite literally, all over the place. It may solve some file location issues!

Re: LXDE not starting

Posted: Sat Nov 28, 2020 8:53 pm
by hbdevelop1
Hi all,

I have another computer successfully running LXDE.
Comparing /var/log/lightdm/lightdm.log in both computers, I've discovered this big difference:

In the computer that runs LXDE sucessfully: [+0.75s] DEBUG: Session pid=1410: Running command /usr/sbin/lightdm-session /usr/bin/startlxde

In the one where LXDE doesn't start: [+5.02s] DEBUG: Session pid=1481: Running command /usr/sbin/lightdm-session /usr/bin/openbox-session

I am not seeing any difference in config files on both computers.
Any clue about the possible root cause ?

Thank you
Hbdevelop

Re: LXDE not starting

Posted: Tue Dec 01, 2020 7:46 am
by drooly
No clue about the "root cause", but it's easy enough to fix: at the login screen, choose the LXDE session instead of the Openbox session.
Unless you actually want the Openbox session.