no audio

Please post all general support questions for LXDE here.
BobCov
Posts: 2
Joined: Thu Jun 18, 2009 3:15 am

Re: no audio

Post by BobCov »

Where are the audio controls? I don't have any sound as far as I can tell, and I wanted to check to see if it was muted, but there are zero audo controls anywhere so far as I can tell.

-Bob

DixieDancer
Posts: 25
Joined: Mon May 04, 2009 1:15 pm

Re: no audio

Post by DixieDancer »

BobCov wrote:Where are the audio controls? I don't have any sound as far as I can tell, and I wanted to check to see if it was muted, but there are zero audo controls anywhere so far as I can tell.
Use PCManFM to find it in /usr/share/applications. It's probably called "Volume Control." When you open it there is a graphic, and it probably shows the sound muted. Just "uncheck" the mute box and raise the little graphical slider up.

Also you may want to simply run the update manager on a regular basis. Several little "bugs" can be fixed just by updating your software.

-Robin

Duncan
Posts: 1
Joined: Sat Sep 26, 2009 6:02 pm

Re: no audio

Post by Duncan »

Bit hacky, but to unmute on login you can make a script that gets called when you login to reset alsa (I couldn't get this to work as rc.local for some reason...)

duncan@acer-netbook:~$ cd .config/autostart/
duncan@acer-netbook:~/.config/autostart$ ls
resetalsa.desktop
duncan@acer-netbook:~/.config/autostart$ cat resetalsa.desktop
[Desktop Entry]
Encoding=UTF-8
Name= ResetAlsa
Comment=Resets Alsa
Exec=/sbin/alsactl restore

Then you can set audio as you like and save the state it with "/sbin/alsactl store".
The above script will load this back in when you restart lxde...
(might need to change permission on asounds.state).
As I said, it's a bit hacky, I'm sure there's a better way ;)

FreelY
Posts: 11
Joined: Tue Oct 06, 2009 11:31 pm
Location: ҒЯ

Re: no audio

Post by FreelY »

Hi
Same problem for me: audio ok with gdm but nothing with slim.
Solved like that:
If you have "exec startlxde" in .xinitrc
Remove this line and try "exec ck-launch-session startlxde"
Image

DixieDancer
Posts: 25
Joined: Mon May 04, 2009 1:15 pm

Re: no audio

Post by DixieDancer »

FreelY wrote:Hi
Same problem for me: audio ok with gdm but nothing with slim.
Solved like that:
If you have "exec startlxde" in .xinitrc
Remove this line and try "exec ck-launch-session startlxde"
I cannot locate any file with ".xinitrc" as part of the name to check it. What directory should I look in for that file? Even the file search option didn't find it.

-Robin

FreelY
Posts: 11
Joined: Tue Oct 06, 2009 11:31 pm
Location: ҒЯ

Re: no audio

Post by FreelY »

What directory should I look in for that file?
/home/ur_login/.xinitrc

The xinit program is used to start the X, but if you are on ubuntu you have to create the file manually (and probably install xinit)
I'm on ArchLinux and the problem is solved for me but there are maybe an other way if you have an other distro...
good luck
Image

Locked