Changing Digital Clock Time Display Mode

The standard theme switcher of LXDE - http://wiki.lxde.org/en/LXAppearance
rtimai
Posts: 3
Joined: Mon Jul 12, 2010 1:58 am

Changing Digital Clock Time Display Mode

Postby rtimai » Mon Jul 12, 2010 3:51 am

How do I change the Digital Clock time display mode from 24-hour to 12-hour? Right now it says Clock Format: %R. Is this where the display mode is changed, and what do I enter in this window? Thanks. Where do I find information like this in LXDE? Thanks!

Pode30
Posts: 3
Joined: Thu Jun 24, 2010 9:42 pm

Re: Changing Digital Clock Time Display Mode

Postby Pode30 » Mon Jul 12, 2010 12:23 pm

You can put one of these:
    %l:%M %p
    %l:%M %P
    %I:%M %p
    %I:%M %P
    %r
Or if you want more run in the terminal:

Code: Select all

date --help

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: Changing Digital Clock Time Display Mode

Postby Marty Jack » Mon Jul 12, 2010 3:48 pm

Where do I find information like this in LXDE? Thanks!


Right below where you enter the format codes it says

Format codes: man 3 strftime

This was hoped to be all the help you would need to find what you could put there.

If you were to read that, you would eventually come to

%H The hour as a decimal number using a 24-hour clock (range 00 to
23).

%I The hour as a decimal number using a 12-hour clock (range 01 to
12).

%k The hour (24-hour clock) as a decimal number (range 0 to 23);
single digits are preceded by a blank. (See also %H.) (TZ)

%l The hour (12-hour clock) as a decimal number (range 1 to 12);
single digits are preceded by a blank. (See also %I.) (TZ)

lars2
Posts: 1
Joined: Tue Mar 12, 2013 1:39 am

Re: Changing Digital Clock Time Display Mode

Postby lars2 » Tue Mar 12, 2013 1:56 am

I'm using zorin lite.. on your post you explain your confusion about changing the 24 hour format to 12 hour format,
you showed that under "Digital Clock settings" the clock format shows %R - All that was need here.. was to change to &r
Yup! that's right.. Just change from UPPER case R', to Lower case r' !!
I have had many hours of frustration w/same problem.. Yea I know it say's use terminal and type ' date --help '
but WHY go to all that, just change to lower case(should have been explained SOMEwhere)!
someday we will have PC's built in our cars - Plug-in - usb drive in dash - boot usb - (touch-screen)
and OFF we go!


Return to “LXAppearance”

Who is online

Users browsing this forum: No registered users and 0 guests