Problem desktop lxde

Questions concerning LXDE themes, interface design, posters, logos and images. If you would like to help with design related tasks of LXDE, please join the Design Project and subscribe to the design mailing list.
drawtine
Posts: 7
Joined: Fri Jul 05, 2013 10:00 am

Problem desktop lxde

Postby drawtine » Fri Jul 05, 2013 10:08 am

Hi, I apologize for my English but I'm Italian and I translate with "Bing Translator".
I have two problems:
When I drag the mouse on the desktop, normally would be a rectangle, type I is an icon, as if you were moving a file.
The second is:
the icons on the desktop have only the inscription, without having the image
How do I resolve these issues? and sorry again for the English

seppalta
Posts: 401
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Problem desktop lxde

Postby seppalta » Fri Jul 05, 2013 9:29 pm

For each item on your desktop, there should be an entry, either a shortcut or .desktop file, in your ~/Desktop directory. You can open either by right clicking and choosing to open with your text editor. If it is a .desktop file, then create or edit the line Icon=path-to-desired-icon. If it is just a shortcut, then you will have to live with a standard file icon, or, I guess in your case nothing. You can always replace the shortcut with a copy of the applications .desktop file. These are located for the most part in /usr/share/applications and /usr/local/share/applications. See
http://lxlinux.com/#11 for more information.

drawtine
Posts: 7
Joined: Fri Jul 05, 2013 10:00 am

Re: Problem desktop lxde

Postby drawtine » Sat Jul 06, 2013 8:13 am

On my desk I have a folder and a .jar file. I do not see the icon of neither.
What can I do?

seppalta
Posts: 401
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Problem desktop lxde

Postby seppalta » Sat Jul 06, 2013 5:49 pm

All the information you need is in http://lxlinux.com/#11. It is a good idea to create, if not already present, a directory, ~/bin for special applications that don't automatically find homes in the root bin folders. Just open your home folder, right click an empty spot and choose "Create Folder". Name it "bin". Move your jar, say xy.jar, to ~/bin. Now, use a text editor to create xy.desktop with

Code: Select all

Exec=java -jar ~/bin/xy.jar
Icon=/usr/share/icons/xy.png
.
For an icon (xy.png), use any 64x64 .png image. Either make one, or find one you like among all the icons in the folders in /usr/share/icons or /usr/share/app-install/icons. Put xy.desktop in your desktop directory, ~/Desktop.

To put an ordinary folder with an icon on the desktop, you need to do a similar thing. Suppose it is named folder. First, move your folder out of the Desktop directory, say you put it into your home directory. Now create folder.desktop, by putting

Code: Select all

Exec=pcmanfm /home/roger/folder
Icon=/usr/share/icons/uv.png
,
where uv.png is your icon choice and roger is your home folder name. Put folder.desktop into your desktop directory.

Make sure you own the desktop files:

Code: Select all

sudo chown roger /home/roger/Desktop/xy.desktop /home/roger/Desktop/uv.desktop
.

drawtine
Posts: 7
Joined: Fri Jul 05, 2013 10:00 am

Re: Problem desktop lxde

Postby drawtine » Sat Jul 06, 2013 6:24 pm

Thank you.
I haven't tried it yet, but I'll tell you that, when I open PCManFM via the Terminal with root permissions, icons are displayed (usually don't).
How come? and how to fix?

drawtine
Posts: 7
Joined: Fri Jul 05, 2013 10:00 am

Re: Problem desktop lxde

Postby drawtine » Sun Jul 07, 2013 11:00 am

now I've put .PNG image on my desktop, and I see icons of theme.

seppalta
Posts: 401
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Problem desktop lxde

Postby seppalta » Sun Jul 07, 2013 7:18 pm

I do not understand your question.

If you put a .desktop file, owned by you, in your Desktop directory, the icon identified in the file should always appear on your desktop for any LXDE distribution.
This is the best way to be sure you always get what you want.

If you just drag an arbitrary file into your Desktop directory, many things (distribution, default themes, file browser, etc) will go into determining what icon, if any, will appear on the desktop. For example, putting a .jpg file into the Desktop directory of a debian 7 LXDE will produce (after rebooting) a thumbnail copy of the image on the actual desktop. See the following picture.
Attachments
1.png
1.png (21.75 KiB) Viewed 3752 times

drawtine
Posts: 7
Joined: Fri Jul 05, 2013 10:00 am

Re: Problem desktop lxde

Postby drawtine » Mon Sep 16, 2013 2:13 pm

After a while, I realized what is the error. The problem is that when I go to choose the theme of icons, select Yes, and then remains empty. Thumbnails of images showing since they do not depend on the theme of icons.
The problem is not solved, however I need help again :(

drawtine
Posts: 7
Joined: Fri Jul 05, 2013 10:00 am

Re: Problem desktop lxde

Postby drawtine » Mon Sep 16, 2013 3:05 pm

this is when i open PCManFM by menu:
Image
and this is when i open it by terminal with "sudo":
Image

seppalta
Posts: 401
Joined: Tue Sep 20, 2011 6:09 am
Location: USA
Contact:

Re: Problem desktop lxde

Postby seppalta » Mon Sep 16, 2013 5:38 pm

I still am bewildered by your problem. If you open Preferenced>Customize Look and Feel>Icon Theme, you are presented with a list of installed themes, for example, GNOME, HighContrast, etc. Choose one and click "Apply". When you open pcmanfm, or a subdirectory like menu:applications as in your picture, you should get the icons from /usr/share/icons/gnome by the entries. Of course, you need to have pcmanfm caliberated to show icons (check the appropriate boxes in Edit>Preferences from the pcmanfm panel). You might want to confirm (check /usr/share/icons/...), or reinstall, the icon theme you choose just to be sure it really is installed.


Return to “LXDE Design Project”

Who is online

Users browsing this forum: No registered users and 1 guest