Bothered by LXDE keyboard bindings in Knoppix 9.1

Please post all general support questions for LXDE here.
Post Reply
Posts: 1
Joined: Wed Jun 08, 2022 7:49 pm

Bothered by LXDE keyboard bindings in Knoppix 9.1

Post by TorstenK »

Dear people familiar with LXDE,

a couple of years ago, I observed issues with LXDE's keyboard bindings on
Raspbian but failed to resolve them.

Now again, I encounter inadequate keyboard mappings on a x86 system (Dell laptop
with Pentium-M CPU), with a Debian-based Knoppix 9.1 system (Linux Microknoppix
5.10.10 #2 SMP PREEMPT Sun Feb 7 02:38:45 CET 2021 i686 GNU/Linux) installed on
the harddisk which uses LXDE as well (LXPanel is version 0.10.1). In Raspbian,
LXDE was combined with Openbox but I do not know whether this is the case in
Knoppix 9.1 ("man openbox" redirects to GNOME-PANEL-CONTROL(1) but there is no
such daemon on the system and I have no idea about Openbox' components).

In Knoppix 9.1, LXDE's Main (or "Start") menu doesn't open on Ctrl-Esc or any
other key combination. Hints on the web refer to a ~/.config/openbox/lxde-rc.xml
file (identical with /etc/skel/.config/openbox/lxde-rc.xml). In Knoppix 9.1,
lines 274 to 278 of this file read

Code: Select all

  <!--keybindings for LXPanel -->
  <keybind key="C-Escape">
      <action name="Execute">
          <command>lxpanelctl menu</command>
When invoked from the command line, "lxpanelctl menu" properly opens the menu
(again, I have no idea whether Openbox is used at all). Lines 177-190 of
/etc/X11/Xsession.d/45knoppix may interfere with keyboard bindings, they read:

Code: Select all

 *lxde|lx*) # Need to change Alt_F1 and Alt_F2 hotkeys in order to make LXDE menu accessible
  sed -i -e 's/as_main_menu_key *=.*$/as_main_menu_key = Disabled/g' \
         -e 's/as_run_command0_key *=.*$/as_run_command0_key = <Alt>F1/g' \
         -e 's/as_command0 *=.*$/as_command0 = lxpanelctl menu/g' \
            "$HOME/.config/compiz-1/compizconfig/Default.ini" 2>/dev/null
  gconftool --type string \
            --set /apps/metacity/global_keybindings/panel_main_menu disabled \
            --set /apps/metacity/global_keybindings/panel_run_dialog disabled \
            --set /apps/metacity/global_keybindings/run_command_1 '<Alt>F1' \
            --set /apps/metacity/global_keybindings/run_command_2 '<Alt>F2' \
            --set /apps/metacity/keybinding_commands/command_1 'lxpanelctl menu' \
            --set /apps/metacity/keybinding_commands/command_2 'lxpanelctl run'
With all these pieces playing together, it's hard to determine where the Alt-F2
or Ctrl-Esc keystroke has got lost.

Second, mnemonics (initial letters working as accelerators) for opening submenus
and for accessing programs would be welcome. This aspect has been discussed
three years ago, in viewtopic.php?t=38637 , as well as in mentioned therein.

Alas, the suggested solution - right-clicking on the desktop and opening the
"Desktop menu" in order to activate a "root menu" - isn't obvious in Knoppix 9.1
(I prefer not to use pointing devices, anyway) and, again, I'd need to determine
whether Openbox is already being used.

At last, I'd like to disable the system-wide Alt-F7 and Alt-F8 keystrokes as
they conflict with application keys, i.e. with File Commander/L's "file find"
and "recall history" functions. I remember having failed to disable them on
Raspbian with LXDE/Openbox, and key assignments are deemed even more complicated
in Knoppix 9.1. (Also failed to disable them in IceWM on Opensuse where at least
"Open menu" hotkeys and mnemonics worked out of the box.)

There is a fourth capability I've never seen in any free Window manager, but
only in commercial systems such as OS/2 Presentation manager or MS Windows'
Program manager and Explorer shells: text in console windows can be marked,
copied and pasted with keystrokes (from the window caption's menu), whereas
X Window-derived managers rely on the mouse for handling console text. This
hasn't changed since KDE 0.4 on FreeBSD 2.2.2 in 1997 and I doubt whether good
keyboard handling will find it's way into free Desktops.

Thank you for your attention,
Regards Torsten
Post Reply