LXDE and repeated periodic sleep entries

Problems with hardware & laptops not being detected or supported during or after install.
Post Reply
bracecomputerlab
Posts: 1
Joined: Tue Oct 03, 2023 9:35 pm

LXDE and repeated periodic sleep entries

Post by bracecomputerlab »

I am cross posting this topic over from Gentoo Linux forum.

https://forums.gentoo.org/viewtopic-t-1 ... 9aa6aed67f

I recently bought a Zhaoxin x86 processor based laptop (KX-6640MA).
I have a USB storage device (SanDisk Extreme 64 GB) I mainly use for testing in development DRM code on 32-bit x86 platform.
It is a customized version of drm-next code base with still in development OpenChrome DRM code.
The Linux kernel is custom compiled to target 586 class processors.
The distribution is Gentoo Linux 32-bit x86.
For this Gentoo Linux installation, I use the default Version 17.0 profile and not desktop profile.
This is to avoid being forced to install Rust compiler to compile a newer version of librsvg.
I personally hate Rust language due to its default SSE2 instruction set requirement on a 32-bit x86 platform.

Due to low memory and graphics requirements, I exclusively use LXDE on this storage device.
But as soon as I get past LXDM based log in screen, as soon as I reach LXDE, forced entry into sleep happens every 60 or so seconds, and I need to press a key on the keyboard to get it out of a blank screen with a white cursor blinking on the top left hand corner.
To prevent a freeze, I need to set ACPI power state support to S1 state or no power state (probably means S0 state) setting (S3 state causes a freeze).
When the screen turns blank with a blinking white cursor on the top left hand corner, if I press a key on the laptop keyboard, I am able to get out of the blank screen 98%of the time.
The rest of 2% of the time, either I loose the screen or gets a distorted screen.
I can still recover from this situation, but it gets tricky since if I press the power button, the computer will enter a shutdown.

Anyway, how can I prevent this periodic forced entry into the sleep mode?
This issue appears to be an LXDE specific issue, is this a bug of LXDE?
I will appreciate if someone can help me on this issue.
Kevin Brace
Brace Computer Laboratory blog
https://bracecomputerlab.com
christopher
Posts: 1
Joined: Sun Oct 29, 2023 5:35 am

Re: LXDE and repeated periodic sleep entries

Post by christopher »

bracecomputerlab wrote: Tue Oct 03, 2023 11:10 pm I am cross posting this topic over from Gentoo Linux forum.

https://forums.gentoo.org/viewtopic-t-1 ... 9aa6aed67f

I recently bought a Zhaoxin x86 processor based laptop (KX-6640MA).
I have a USB storage device (SanDisk Extreme 64 GB) I mainly use for testing in development DRM code on 32-bit x86 platform.
It is a customized version of drm-next code base with still in development OpenChrome DRM code.
The Linux kernel is custom compiled to target 586 class processors.
The distribution is Gentoo Linux 32-bit x86.bloxd io
For this Gentoo Linux installation, I use the default Version 17.0 profile and not desktop profile.
This is to avoid being forced to install Rust compiler to compile a newer version of librsvg.
I personally hate Rust language due to its default SSE2 instruction set requirement on a 32-bit x86 platform.

Due to low memory and graphics requirements, I exclusively use LXDE on this storage device.
But as soon as I get past LXDM based log in screen, as soon as I reach LXDE, forced entry into sleep happens every 60 or so seconds, and I need to press a key on the keyboard to get it out of a blank screen with a white cursor blinking on the top left hand corner.
To prevent a freeze, I need to set ACPI power state support to S1 state or no power state (probably means S0 state) setting (S3 state causes a freeze).
When the screen turns blank with a blinking white cursor on the top left hand corner, if I press a key on the laptop keyboard, I am able to get out of the blank screen 98%of the time.
The rest of 2% of the time, either I loose the screen or gets a distorted screen.
I can still recover from this situation, but it gets tricky since if I press the power button, the computer will enter a shutdown.

Anyway, how can I prevent this periodic forced entry into the sleep mode?
This issue appears to be an LXDE specific issue, is this a bug of LXDE?
I will appreciate if someone can help me on this issue.
To prevent this issue from happening, you can try disabling sleep and hibernation modes in your Linux system. To do this, you can disable the following systemd targets: sleep.target, suspend.target, hibernate.target, and hybrid-sleep.target.

Alternatively, you can try modifying the systemd configuration by setting the IdleAction to ignore in /etc/systemd/logind.conf.
andreen
Posts: 6
Joined: Thu Aug 03, 2023 6:43 am

Re: LXDE and repeated periodic sleep entries

Post by andreen »

Alternatively, you can modify the systemd configuration by editing the slither io /etc/systemd/logind.conf file. Look for the IdleAction parameter and set it to ignore. If the parameter doesn't exist, you can add it to the file.
Post Reply