screen resolution problem

All questions and problems regarding the installation and upgrades of LXDE from USB Stick, Live CD or Web.
glogo
Posts: 12
Joined: Thu Apr 16, 2009 3:25 am
Location: india

screen resolution problem

Postby glogo » Thu Apr 16, 2009 3:43 am

Hello,

thank you for this excellent DE.

loaded in Debian Lenny, on very old architecture but running smoothly.

only one thing bothers me. every time we log in , the screen res goes back to what it should not be. is there any way to "hard code" this res that we want, like in the xorg.conf file, which is now almost empty?

cannot seem to get it to work and tired of changing the res on every login with lxrandr.

thanks for any help.

G

maces
Posts: 503
Joined: Sat Oct 25, 2008 6:04 pm
Contact:

Re: screen resolution problem

Postby maces » Thu Apr 16, 2009 3:53 pm

Welcome in the Forum

I would add the following line to my "/home/maces/.config/lxsession/LXDE/autostart" file:

Code: Select all

@xrandr --output VGA --mode 1024x768

This should set the screen to the size you want. For more detailed configuration see the manpage of xrandr and this wikipage.

maces

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: screen resolution problem

Postby Marty Jack » Thu Apr 16, 2009 5:40 pm

I would leave out the "@" when you add that line. Otherwise xrandr will be relaunched in a loop, since "@" requests lxsession to restart the process every time it exits.

maces
Posts: 503
Joined: Sat Oct 25, 2008 6:04 pm
Contact:

Re: screen resolution problem

Postby maces » Thu Apr 16, 2009 6:39 pm

Marty Jack wrote:I would leave out the "@" when you add that line. Otherwise xrandr will be relaunched in a loop, since "@" requests lxsession to restart the process every time it exits.

Oops, yes you're right. Without the '@'.

maces

glogo
Posts: 12
Joined: Thu Apr 16, 2009 3:25 am
Location: india

Re: screen resolution problem

Postby glogo » Tue Apr 21, 2009 2:40 pm

Hello and thanks for your suggestions,

first off, I cannot find any lxsession directory under my .config dir in my home dir. there is lxpanel and lxterminal, but neither of them have any such file as mentioned in them. each user account should have one, right? otherwise, I set the system up under another account. maybe I should look there, too.

so, what if I do something like this:

Code: Select all

xrandr --delmode <output> <name>

where I am assuming the name is 1152x768 which is what the server defaults to. the next mode is the one I would like to use, you guessed it correctly, 1024x768. but I am not sure what output is. would it be something like "stdout"? Tried that, too. Frankly, I am not very good at reading the man pages. I find I need examples of code, not just these dry syntaxes. I guess that is what a wiki is for. But I cannot make heads or tails of that entry either.

anyway, why I don't have a lxsession folder I would also like to know. It would have been so nice, just to have a clean getaway fix for this niggling, irritating problem.

TIA
glogo

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: screen resolution problem

Postby Marty Jack » Tue Apr 21, 2009 9:25 pm

The system wide autostart file is /etc/xdg/lxsession/LXDE/autostart

glogo
Posts: 12
Joined: Thu Apr 16, 2009 3:25 am
Location: india

Re: screen resolution problem

Postby glogo » Wed Apr 22, 2009 6:01 am

Hello, thanks for your help.

here is the updated file.
cat /etc/xdg/lxsession/LXDE/autostart

Code: Select all

@lxde-settings
@xscreensaver -no-splash
@lxpanel --profile LXDE
@pcmanfm -d
xrandr --output VGA --mode 1024x768


but it still does not work. logout and login restarts the xserver, right? so, I know it's silly, but I rebooted then also. to no effect.

when I tried this command on the command line, it gives an error that output VGA cannot be found. But I assume any standard monitor will be termed as VGA. How do I find out what is the name of my output? or what other things can we try to fix it?

Seems so difficult, should be straightforward, I would have thought.

thanks again
glogo

PS: don't know what happened. ran that code in the command line again, this time no error, so VGA must be correct, but still it is doing nothing at all. Is there not somewhere a file that lists all these modes, and can I not just go there and delete everything I don't want? :?:

glogo
Posts: 12
Joined: Thu Apr 16, 2009 3:25 am
Location: india

Re: screen resolution problem -- SOLVED

Postby glogo » Wed Apr 22, 2009 2:15 pm

It's fixed. the correct code

Code: Select all

xrandr -s 1024x768


this line is appended in the file /etc/xdg/lxsession/LXDE/autostart

that is all that was needed, but what a process to get there.

the answer was found in a recent post here about setting the default resolution. a little hard to find, as the words "screen", "resolution" etc. are deemed too common to be worthy of a search. but finally found it. thanks for all your support. I know even if you don't respond, you are all rooting for a new user of LXDE and 'nix!
warmly
glogo

Marty Jack
Posts: 381
Joined: Mon Mar 23, 2009 5:14 am

Re: screen resolution problem

Postby Marty Jack » Wed Apr 22, 2009 6:01 pm

Good you got it working.

As I mentioned in that other thread it is worth looking into why you don't start in the correct resolution to begin with. This answer is found in the X startup log /var/log/Xorg.0.log and it may be an xorg issue or a monitor isn't detected correctly issue.

glogo
Posts: 12
Joined: Thu Apr 16, 2009 3:25 am
Location: india

Re: screen resolution problem

Postby glogo » Sun Apr 26, 2009 7:52 am

Yes, thanks, happily it finally worked.

as an interesting side note. xorg.conf manipulation does nothing. I edited that file to include only the resolutions I wanted to see in the list. nothing doing.

and strangely, when I also re-edited the other file (/etc/xdg/lxsession/LXDE/autostart) and took out the command "xrandr -s 1024x768", see there, that old, weird 1152x768 res, that kept getting thrown in there, never came back. (It had bothered me. because square and round were never square and round with that res, when working with GIMP, etc, otherwise, I would not have cared much.)

It's as if some file somewhere got changed from that command, and even though I took it out, it still always boots to the standard, desired 1024x768. So, WHERE is that file? Or how does this system work? Seems like you could just edit that file... but forget about editing xorg.conf. :roll: no effect.

Anyway, it works, all is well with the world, now If could just get some of these apps working... but that is a topic for others forums.

thanks again
glogo


Return to “Installation and Upgrade of LXDE”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest