LXDE et Gentoo

Moderator: Mario Behling

aramis_qc
Posts: 2
Joined: Sat Oct 24, 2009 7:24 pm
Location: Québec, Canada

LXDE et Gentoo

Postby aramis_qc » Sat Oct 24, 2009 7:45 pm

Bonjour,

Je découvre LXDE. C'est tout récent. Je viens d'en compléter l'installation sous Gentoo ~x86 (unstable). J'aime bien ce que je vois et j'entends poursuivre l'utilisation de ce bureau à l'avenir. Ce faisant, je vais dans quelques jours installer une Gentoo x86 (stable) et convertir ma Funtoo unstable en Funtoo stable. Il est évident que LXDE sera le bureau des ces prochains environnements.

J'ai repris pour le bénéfice des utilisateurs francophones le guide d'installation The LXDE Configuration HOWTO dont j'ai fait une version française tout en y allant de quelques ajouts. Cette version française est disponible sur le wiki de Gentoo-Québec. Il sera complété dans les jours qui viennent.

CaptainBlood
Posts: 5
Joined: Tue Mar 02, 2010 2:32 pm

Re: LXDE et Gentoo

Postby CaptainBlood » Wed Mar 03, 2010 3:20 am

Salut,
J'ai un problème d'intégration de LXDE+gnome-keyring, en particulier la non sauvegarde des passwords dans networkmanager, en saisie à la volée qu'en paramètre de la connection ?
Peut-être as tu de l'expérience en ce domaine ?

Merci de votre attention.
A+

aramis_qc
Posts: 2
Joined: Sat Oct 24, 2009 7:24 pm
Location: Québec, Canada

Re: LXDE et Gentoo

Postby aramis_qc » Wed Mar 03, 2010 3:26 am

Désolé... j'ai abandonné depuis.

kevinpeter
Posts: 4
Joined: Sat Feb 05, 2011 11:04 am

Re: LXDE et Gentoo

Postby kevinpeter » Sat Feb 05, 2011 11:08 am

However if I want to use slim, the background of the slim login window stays as the background of my LXDE session, which is not what I want of course. Here is my slim.conf. I suppose something's wrong but I can't see what.
Code:
$ cat /etc/slim.conf
default_path /bin:/usr/bin:/usr/local/bin
default_xserver /usr/bin/X
xserver_arguments -nolisten tcp -br -deferglyphs 16

halt_cmd /sbin/shutdown -h now
reboot_cmd /sbin/shutdown -r now
console_cmd /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
suspend_cmd /usr/sbin/hibernate-ram # not useful as I can't seem to suspend from slim anyway

xauth_path /usr/bin/xauth

authfile /var/run/slim.auth

numlock on

# login_cmd exec /bin/sh - ~/.xinitrc %session
#login_cmd exec /bin/bash -login ~/.xinitrc %session
#login_cmd exec /bin/bash -login /etc/X11/xinit/xinitrc
# I have mostly tried the two settings below but in both cases I keep the slim background in my LXDE session
# login_cmd /usr/bin/lxsession -s LXDE -e LXDE
login_cmd exec startlxde

sessionstart_cmd /usr/bin/sessreg -a -l :0.0 %user
sessionstop_cmd /usr/bin/sessreg -d -l :0.0 %user

daemon yes

sessions lxde,xfce4,icewm,wmaker,blackbox

screenshot_cmd import -window root /slim.png

welcome_msg Welcome to %host

shutdown_msg The system is halting...
reboot_msg The system is rebooting...

current_theme default, flower2, gentoo, lake, lotus-midnight, lotus-sage, mindlock, rainbow, rear-window, slim-gentoo-simple, wave

lockfile /var/run/slim.pid

logfile /var/log/slim.log


Return to “French LXDE Forum / Forum français LXDE”

Who is online

Users browsing this forum: No registered users and 0 guests